Verify label stack in TE tunnels

July 13, 2010 at 12:07 am | Posted in Blogroll | 1 Comment

TOPOLOGY

 

R1 —– R2 —– R3 —— R4

CONFIGURATION

 

R1#
mpls traff tunnel
int lo0
 ip add 1.1.1.1 255.255.255.255

int fa0/0
 ip add 12.0.0.1 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 100000 100000

router ospf 1
 mpls traffic-eng router-id loo0
 mpls traffic-eng area 0
 net 1.1.1.1 0.0.0.0 area 0
 net 12.0.0.1 0.0.0.0 area 0
int tunnel14
 ip unnumbered lo0
 tunnel mode mpls traffic-eng
 tunnel destination 4.4.4.4
 tunnel mpls traffic-eng bandwidth 50000
 tunnel mpls traffic-eng path-option 10 dynamic
interface Tunnel104
 ip unnumbered Loopback0
 tunnel destination 4.4.4.4
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 10000
 tunnel mpls traffic-eng path-option 10 dynamic
ip route 40.40.40.0 255.255.255.0 Tunnel104
ip route 44.44.44.0 255.255.255.0 Tunnel14
R2#
mpls traff tunnel
int fa0/0
 ip address 12.0.0.2 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 100000 100000

int fa0/1
 ip address 23.0.0.2 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 100000 100000

int lo0
 ip add 2.2.2.2 255.255.255.255

router ospf 1
 mpls traffic-eng area 0
 mpls traffic-eng router-id loo0
 net 0.0.0.0 255.255.255.255 area 0
R3#

mpls traff tunnel

int lo0
 ip add 3.3.3.3 255.255.255.255
router ospf 1
 mpls traffic-eng area 0
 mpls traffic-eng router-id loo0
 net 0.0.0.0 255.255.255.255 area 0
int fa0/0
 ip address 34.0.0.3 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 100000 100000

int fa0/1
 ip add 23.0.0.3 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 100000 100000
 
R4#

mpls traff tunnel

int lo0
 ip add 4.4.4.4 255.255.255.255
router ospf 1
 mpls traffic-eng area 0
 mpls traffic-eng router-id loo0
 net 0.0.0.0 255.255.255.255 area 0
int fa0/0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 100000 100000

int fa0/1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 100000 100000
int tunnel41
 ip unnumbered lo0
 tunnel mode mpls traffic-eng
 tunnel destination 1.1.1.1
 tunnel mpls traffic-eng bandwidth 50000
 tunnel mpls traffic-eng path-option 10 dynamic

!
interface Loopback40
 ip address 40.40.40.40 255.255.255.0
!
interface Loopback44
 ip address 44.44.44.44 255.255.255.0

TE VERIFICATION

R1#show mpls traffic-eng tunnels  

Name: R1_t14                              (Tunnel14) Destination: 4.4.4.4
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 3)

  Config Parameters:
    Bandwidth: 50000    kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 50000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/0, 20
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 4.4.4.4, Tun_Id 14, Tun_Instance 28
    RSVP Path Info:
      My Address: 12.0.0.1  
      Explicit Route: 12.0.0.2 23.0.0.2 23.0.0.3 34.0.0.3
                      34.0.0.4 4.4.4.4
      Record   Route:   NONE
      Tspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
  History:
    Tunnel:
      Time since created: 27 minutes, 32 seconds
      Time since path change: 22 minutes, 2 seconds
      Number of LSP IDs (Tun_Instances) used: 28
    Current LSP:
      Uptime: 22 minutes, 2 seconds
    Prior LSP:
      ID: path option 10 [25]
      Removal Trigger: path error

Name: R1_t104                             (Tunnel104) Destination: 4.4.4.4
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 3)

  Config Parameters:
    Bandwidth: 10000    kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 10000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/0, 23
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 4.4.4.4, Tun_Id 104, Tun_Instance 1
    RSVP Path Info:
      My Address: 12.0.0.1  
      Explicit Route: 12.0.0.2 23.0.0.2 23.0.0.3 34.0.0.3
                      34.0.0.4 4.4.4.4
      Record   Route:   NONE
      Tspec: ave rate=10000 kbits, burst=1000 bytes, peak rate=10000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=10000 kbits, burst=1000 bytes, peak rate=10000 kbits
  History:
    Tunnel:
      Time since created: 11 minutes, 2 seconds
      Time since path change: 11 minutes
      Number of LSP IDs (Tun_Instances) used: 1
    Current LSP:
      Uptime: 11 minutes

LSP Tunnel R4_t41 is signalled, connection is up
  InLabel  : FastEthernet0/0, implicit-null
  OutLabel :  –
  RSVP Signalling Info:
       Src 4.4.4.4, Dst 1.1.1.1, Tun_Id 41, Tun_Instance 14
    RSVP Path Info:
      My Address: 1.1.1.1  
      Explicit Route:  NONE
      Record   Route:   NONE
      Tspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits

CHECK LABEL STACK DETAILS

R1#show mpls forwarding-table
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop   
Label  Label or VC   or Tunnel Id      Switched      interface             
16     Pop Label     2.2.2.2/32        0             Fa0/0      12.0.0.2   
17     Pop Label     23.0.0.0/24       0             Fa0/0      12.0.0.2   
18     17            3.3.3.3/32        0             Fa0/0      12.0.0.2   
19     18            34.0.0.0/24       0             Fa0/0      12.0.0.2   
20     22            4.4.4.4/32        0             Fa0/0      12.0.0.2   
22     Pop Label [T] 44.44.44.0/24     0             Tu14       point2point
23     Pop Label [T] 40.40.40.0/24     0             Tu104      point2point

[T]     Forwarding through a LSP tunnel.
        View additional labelling info with the ‘detail’ option

R1#show mpls forwarding-table  44.44.44.0 detail
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop   
Label  Label or VC   or Tunnel Id      Switched      interface             
22     Pop Label     44.44.44.0/24     0             Tu14       point2point
        MAC/Encaps=14/18, MRU=1500, Label Stack{20}, via Fa0/0
        CA0105800008CA00058000088847 00014000
        No output feature configured

R1#show mpls forwarding-table  40.40.40.0 detail
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop   
Label  Label or VC   or Tunnel Id      Switched      interface             
23     Pop Label     40.40.40.0/24     0             Tu104      point2point
        MAC/Encaps=14/18, MRU=1500, Label Stack{23}, via Fa0/0
        CA0105800008CA00058000088847 00017000
        No output feature configured

R2#show mpls forwarding-table
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop   
Label  Label or VC   or Tunnel Id      Switched      interface             
16     Pop Label     1.1.1.1/32        3034          Fa0/0      12.0.0.1   
17     Pop Label     3.3.3.3/32        0             Fa0/1      23.0.0.3   
18     Pop Label     34.0.0.0/24       0             Fa0/1      23.0.0.3   
20     19            1.1.1.1 14 [28]   3104          Fa0/1      23.0.0.3   
21     Pop Label     4.4.4.4 41 [14]   0             Fa0/0      12.0.0.1   
22     21            4.4.4.4/32        0             Fa0/1      23.0.0.3   
23     23            1.1.1.1 104 [1]   3694          Fa0/1      23.0.0.3

R2#show mpls traffic-eng tunnels

LSP Tunnel R1_t14 is signalled, connection is up
  InLabel  : FastEthernet0/0, 20
  OutLabel : FastEthernet0/1, 19
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 4.4.4.4, Tun_Id 14, Tun_Instance 28
    RSVP Path Info:
      My Address: 23.0.0.2  
      Explicit Route: 23.0.0.3 34.0.0.3 34.0.0.4 4.4.4.4
      Record   Route:   NONE
      Tspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits

LSP Tunnel R1_t104 is signalled, connection is up
  InLabel  : FastEthernet0/0, 23
  OutLabel : FastEthernet0/1, 23
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 4.4.4.4, Tun_Id 104, Tun_Instance 1
    RSVP Path Info:
      My Address: 23.0.0.2  
      Explicit Route: 23.0.0.3 34.0.0.3 34.0.0.4 4.4.4.4
      Record   Route:   NONE
      Tspec: ave rate=10000 kbits, burst=1000 bytes, peak rate=10000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=10000 kbits, burst=1000 bytes, peak rate=10000 kbits

R3#show mpls forwarding-table
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop   
Label  Label or VC   or Tunnel Id      Switched      interface             
16     Pop Label     2.2.2.2/32        0             Fa0/1      23.0.0.2   
17     16            1.1.1.1/32        3118          Fa0/1      23.0.0.2   
18     Pop Label     12.0.0.0/24       570           Fa0/1      23.0.0.2   
19     Pop Label     1.1.1.1 14 [28]   3288          Fa0/0      34.0.0.4   
21     Pop Label     4.4.4.4/32        0             Fa0/0      34.0.0.4   
22     21            4.4.4.4 41 [14]   0             Fa0/1      23.0.0.2   
23     Pop Label     1.1.1.1 104 [1]   3858          Fa0/0      34.0.0.4 

R3#show mpls traffic-eng tunnels

LSP Tunnel R1_t14 is signalled, connection is up
  InLabel  : FastEthernet0/1, 19
  OutLabel : FastEthernet0/0, implicit-null
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 4.4.4.4, Tun_Id 14, Tun_Instance 28
    RSVP Path Info:
      My Address: 34.0.0.3  
      Explicit Route: 34.0.0.4 4.4.4.4
      Record   Route:   NONE
      Tspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits

LSP Tunnel R1_t104 is signalled, connection is up
  InLabel  : FastEthernet0/1, 23
  OutLabel : FastEthernet0/0, implicit-null
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 4.4.4.4, Tun_Id 104, Tun_Instance 1
    RSVP Path Info:
      My Address: 34.0.0.3  
      Explicit Route: 34.0.0.4 4.4.4.4
      Record   Route:   NONE
      Tspec: ave rate=10000 kbits, burst=1000 bytes, peak rate=10000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=10000 kbits, burst=1000 bytes, peak rate=10000 kbits
 

Continue Reading Verify label stack in TE tunnels…

Advertisement of route into BGP: network / redistribution / aggregation

June 1, 2010 at 6:54 am | Posted in Blogroll | Leave a comment

If a prefix originates into BGP via 3 different methods: network/redistribution/aggregate, then below is the order of preference. The highest preference will be installed into the BGP table.

  1. Network statement with static route
  2. Redistribution of static route
  3. Aggregation

 Example below demonstrates the preferences.

 

R1#srsr
router bgp 13
 no synchronization
 bgp log-neighbor-changes
 network 1.1.0.0 mask 255.255.0.0
 network 1.1.1.1 mask 255.255.255.255
 aggregate-address 1.1.0.0 255.255.0.0
 redistribute static
 neighbor 13.0.0.3 remote-as 13
 no auto-summary

R3#srsr
router bgp 13
 no synchronization
 bgp log-neighbor-changes
 neighbor 13.0.0.1 remote-as 13

Without static or IGP route for 1.1.0.0/16, then the only way 
router originates 1.1.0.0/16 is via Aggregation

R3#sh ip bgp 1.1.0.0/16
BGP routing table entry for 1.1.0.0/16, version 7
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  Local, (aggregated by 13 13.0.0.1)
    13.0.0.1 from 13.0.0.1 (13.0.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate, best

R1(config)#ip route 1.1.0.0 255.255.0.0 Null0

1.1.0.0/16 leant via all three ways (network, redistribution, aggregate), 
best is via Network Statement

R3#sh ip bgp 1.1.0.0/16
BGP routing table entry for 1.1.0.0/16, version 8
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Not advertised to any peer
  Local
    13.0.0.1 from 13.0.0.1 (13.0.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best

R1(config)#router bgp 13
R1(config-router)#no  network 1.1.0.0 mask 255.255.0.0

1.1.0.0/16 is advertised into BGP via 
both redistribution of static & aggregation, 
then redistribution take precedence.

R3#sh ip bgp 1.1.0.0/16
BGP routing table entry for 1.1.0.0/16, version 9
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Not advertised to any peer
  Local
    13.0.0.1 from 13.0.0.1 (13.0.0.1)
      Origin incomplete, metric 0, localpref 100, valid, internal, best

R1(config-router)#no ip route 1.1.0.0 255.255.0.0 Null0

Static is removed, then only ways 1.1.0.0/16 
advertised into BGP is via aggregation

R3#sh ip bgp 1.1.0.0/16
BGP routing table entry for 1.1.0.0/16, version 10
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Not advertised to any peer
  Local, (aggregated by 13 13.0.0.1)
    13.0.0.1 from 13.0.0.1 (13.0.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate, best

Routing loop due to Static pointing to not directly connected IP

May 31, 2010 at 11:16 pm | Posted in Blogroll | Leave a comment

Static routes that point to an IP that is not locally connected are hidden bombs that can explode any time. This is because this sort of static routes do not show up in the routing table if the next hop is not routable or routed via default route. In order for the static route to be install in the routing table, the next hop need to be routed via a more specific route than the default route.

As a result, these sort of static routes (pointing to nowhere, or I call it “pointing to hell”) may bite you at a later stage, even when you make an unlikely related change.

This example show that the routing loop starts to kick in, once we add a summary route somewhere else.

PE1#    

interface Serial1/1
 description Connection to PE3
 ip address 13.0.0.1 255.255.255.0

ip route 123.123.123.0 255.255.255.0 3.3.3.1 name Static_to_Hell

router bgp 13
 network 123.123.123.0 mask 255.255.255.0
 redistribute static
 neighbor 13.0.0.3 remote-as 13
 neighbor 13.0.0.3 next-hop-self

PE3#
!
interface Serial1/2
 description Connection to PE1
 ip address 13.0.0.3 255.255.255.0
!
interface Serial1/3
 description Connection to iNET2
 ip address 23.0.0.3 255.255.255.0
!
interface Loopback333
 description Just to similate specific of aggregation route
 ip address 3.3.3.3 255.255.255.255

router bgp 13
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 aggregate-address 3.3.3.0 255.255.255.0
 redistribute connected
 neighbor 13.0.0.1 remote-as 13
 neighbor 13.0.0.1 next-hop-self
 neighbor 23.0.0.2 remote-as 2
 no auto-summary

iNET2#sh run int s1/1
Building configuration...

Current configuration : 86 bytes
!
interface Serial1/1
 description Connection to PE3
 ip address 23.0.0.2 255.255.255.0

router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 23.0.0.3 remote-as 13
 neighbor 23.0.0.3 default-originate
 no auto-summary

PE1#sh ip route 123.123.123.0
Routing entry for 123.123.123.0/24
  Known via "static", distance 1, metric 0
  Redistributing via bgp 13
  Advertised by bgp 13
  Routing Descriptor Blocks:
  * 3.3.3.1
      Route metric is 0, traffic share count is 1

PE3#sh ip route 123.123.123.0 
Routing entry for 123.123.123.0/24
  Known via "bgp 13", distance 200, metric 0, type internal
  Last update from 13.0.0.1 00:01:32 ago
  Routing Descriptor Blocks:
  * 13.0.0.1, from 13.0.0.1, 00:01:32 ago
      Route metric is 0, traffic share count is 1
      AS Hops 0

iNET2#traceroute 123.123.123.123 ttl 1 10

Type escape sequence to abort.
Tracing the route to 123.123.123.123

  1 23.0.0.3 36 msec 12 msec 16 msec
  2 13.0.0.1 [AS 13] 20 msec 72 msec 12 msec
  3 13.0.0.3 [AS 13] 24 msec 44 msec 68 msec
  4 13.0.0.1 [AS 13] 48 msec 44 msec 64 msec
  5 13.0.0.3 [AS 13] 16 msec 48 msec 76 msec
  6 13.0.0.1 [AS 13] 96 msec 60 msec 52 msec
  7 13.0.0.3 [AS 13] 80 msec 140 msec 80 msec
  8 13.0.0.1 [AS 13] 76 msec 88 msec 72 msec
  9 13.0.0.3 [AS 13] 100 msec 76 msec 116 msec
 10 13.0.0.1 [AS 13] 32 msec 120 msec 128 msec

PE3#c
Enter configuration commands, one per line.  End with CNTL/Z.
PE3(config)#router bgp 13
PE3(config-router)# no aggregate-address 3.3.3.0 255.255.255.0
PE3(config-router)#end

PE1#sh run | in ip route
ip route 123.123.123.0 255.255.255.0 3.3.3.1 name Static_to_Hell

PE1#sh ip route 123.123.123.0
% Network not in table

NO MORE LOOPING

iNET2#traceroute 123.123.123.123 ttl 1 10

Type escape sequence to abort.
Tracing the route to 123.123.123.123

  1  *  *  *
  2  *  *  *

TCL script

May 28, 2010 at 12:38 am | Posted in Blogroll, TCL | 2 Comments

Here’s my fav:

puts [open "flash:ping-script" w+] {
puts ""
show clock
puts " -- Start pinging ..."
puts ""
foreach i {
61.88.88.88
2.2.2.2
123.123.123.123
33.33.33.33
google.com
www.news.com.au
} {
if {[regexp "!" [exec "ping $i rep 3 time 1"]]} {puts "$i OK"} else {puts "$i ***unreachable***"}}
show clock
puts " -- Pings stopped."
puts ""
}
(tcl)# quit

Then to execute the file from enabled mode:
#tclsh ping-script

Reference:

http://blog.ru.co.za/2009/03/28/tcl-script-variations/#more-684 

First method is kinda cool, since you creating an executable file in flash that is there, to be used whenever.
(the w+ means to write/overwrite, or if you want to append the file use a+ instead)
#tclsh
puts [open "flash:ping-script.tcl" w+] {
foreach IP {
150.1.1.1
204.12.1.254
} { puts [ exec "ping $IP re 2" ] }
}
(tcl)#tclquit

Then to execute the file from global configuration mode:
#tclsh ping-script.tcl

Second method is pretty pointless unless you writing a beeg script and actually using ‘process’ for what it is meant. Problem here is once you exit tcl-shell, the info is gone.
To execute while in tclsh just type the name
#tclsh
proc ping-script {} {
foreach IP {
150.1.1.1
204.12.1.254
} { puts [ exec "ping $IP re 2" ] }
}
(tcl)#ping-script

Third method is the most common one I have seen guys use. And its not bad, but still to much syntax to remember off-hand.
This will execute the ping command once <RETURN> is pressed at the last line.
#tclsh
foreach IP {
150.1.1.1
204.12.1.254
} { puts [ exec "ping $IP re 2" ] }

Best method, is a almost always the shortest one. Again execution will auto follow once the script is complete.
(oh and ‘IP’ is just a arbitrary name I used, not a tcl value)
#tclsh
foreach IP {
150.1.1.1
204.12.1.254
} {ping $IP re 2}

TE Affinity Bits

May 18, 2010 at 10:31 pm | Posted in Blogroll | Leave a comment

By default, Affinity of a TE tunnel is 0x0/0xFFFF. This means, this tunnel can only be placed accross links with affinity attributes 0x0.

If we want a tunnel that can cross any link, we need to set its affinity to 0x0 mask 0x0.
R1#sh mpls traffic-eng tunnels tu0

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: down   Path: not valid   Signalling: Down
    path option 5, type explicit R1_R2
    path option 10, type dynamic

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled

R1(config-if)#int tun0
R1(config-if)#tunnel mpls traffic-eng affinity 0x0 mask 0x0
R1(config-if)#end
R1#sh
*May 18 21:25:17.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R1#sh mpls t
*May 18 21:25:17.179: %SYS-5-CONFIG_I: Configured from console by console
R1#sh mpls tra
R1#sh mpls traffic-eng tun
R1#sh mpls traffic-eng tunnels

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 2)
    path option 5, type explicit R1_R2

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0x0
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/1, 24
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 408
    RSVP Path Info:
      My Address: 14.0.0.1  
      Explicit Route: 14.0.0.4 24.0.0.4 24.0.0.2 2.2.2.2
      Record   Route:   NONE

TE tunnel placement via explicit & dynamic paths

May 18, 2010 at 1:35 am | Posted in Blogroll, MPLS, Traffic Engineering | Leave a comment

R1#sh run
Building configuration…

Current configuration : 2645 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip source-route
ip cef
!
!
!
!
!
!        
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng reoptimize timers frequency 10
mpls traffic-eng reoptimize timers delay installation 5
mpls traffic-eng auto-bw timers frequency 5
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 6 6
 tunnel mpls traffic-eng bandwidth 55000
 tunnel mpls traffic-eng path-option 5 explicit name R1_R2
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 5 5
 tunnel mpls traffic-eng bandwidth 50000
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.0.0.1 255.255.255.0
 speed auto
 duplex auto
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth 90000 90000
!
interface FastEthernet0/1
 ip address 14.0.0.1 255.255.255.0
 speed auto
 duplex auto
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth 90000 90000
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 12.0.0.1 0.0.0.0 area 0
 network 14.0.0.1 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
ip explicit-path name R1_R4_R3_R2 enable
 next-address 14.0.0.4
 next-address 34.0.0.3
 next-address 23.0.0.2
!
ip explicit-path name R1_R2 enable
 next-address 12.0.0.2
!
R1(config)#mpls traffic-eng auto-bw timers frequency ?
  <1-604800>  seconds between auto-bw

R1(config)#mpls traffic-eng reoptimize events link-up

R1(config)#mpls traffic-eng reoptimize timers delay installation ?
  <0-3600>  seconds to delay replacement of tunnel LSP

R1(config)#mpls traffic-eng reoptimize timers delay installation 5
R1(config)#mpls traffic-eng reoptimize timers frequency ?
  <0-604800>  seconds between reoptimizations (0 disables reoptimization)

R1(config)#mpls traffic-eng reoptimize timers frequency 10
R1#

interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 6 6
 tunnel mpls traffic-eng bandwidth 50000
 tunnel mpls traffic-eng path-option 5 explicit name R1_R2 lockdown
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 5 5
 tunnel mpls traffic-eng bandwidth 50000
 tunnel mpls traffic-eng path-option 10 dynamic
ip explicit-path name R1_R4_R3_R2 enable
 next-address 14.0.0.4
 next-address 34.0.0.3
 next-address 23.0.0.2

ip explicit-path name R1_R2 enable
 next-address 12.0.0.2

R1#sh mpls traffic-eng tunnels summary
Signalling Summary:
    LSP Tunnels Process:            running
    Passive LSP Listener:           running
    RSVP Process:                   running
    Forwarding:                     enabled
    Head: 2 interfaces, 2 active signalling attempts, 2 established
          34 activations, 32 deactivations
          0 SSO recovery attempts, 0 SSO recovered
    Midpoints: 0, Tails: 0
    Periodic reoptimization:        every 10 seconds, next in 1 seconds
    Periodic FRR Promotion:         Not Running
    Periodic auto-bw collection:    every 5 seconds, next in 2 seconds

R1#sh mpls traffic-eng tunnels tun0   

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 3)

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/1, 22
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 281
    RSVP Path Info:
      My Address: 14.0.0.1  
      Explicit Route: 14.0.0.4 34.0.0.4 34.0.0.3 23.0.0.3
                      23.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 1 (TE)
    Explicit Route: 12.0.0.1 12.0.0.2 2.2.2.2
  History:
    Tunnel:
      Time since created: 2 hours, 16 minutes
      Time since path change: 6 minutes, 50 seconds
      Number of LSP IDs (Tun_Instances) used: 281
    Current LSP:
      Uptime: 6 minutes, 50 seconds
    Prior LSP:
      ID: path option 10 [280]
      Removal Trigger: path error
R1#sh mpls traffic-eng tunnels tun1

Name: R1_t1                               (Tunnel1) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 1)

  Config Parameters:
    Bandwidth: 50000    kbps (Global)  Priority: 5  5   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 50000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/0, implicit-null
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 1, Tun_Instance 132
    RSVP Path Info:
      My Address: 12.0.0.1  
      Explicit Route: 12.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 1 (TE)
    Explicit Route: 12.0.0.1 12.0.0.2 2.2.2.2
  History:
    Tunnel:
      Time since created: 54 minutes, 44 seconds
      Time since path change: 25 minutes, 57 seconds
      Number of LSP IDs (Tun_Instances) used: 132
    Current LSP:
      Uptime: 6 minutes, 54 seconds
      Selection: reoptimization
    Prior LSP:
      ID: path option 10 [39]
      Removal Trigger: configuration changed
R1#c
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int tun1
R1(config-if)#shut
R1(config-if)#end
R1#
R1#
R1#
R1#sh mpls  traffic-eng tunnels tun0

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 3)
    path option 5 reoptimization in progress

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/1, 22
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 382
    RSVP Path Info:
      My Address: 14.0.0.1  
      Explicit Route: 14.0.0.4 34.0.0.4 34.0.0.3 23.0.0.3
                      23.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 1 (TE)
    Explicit Route: 12.0.0.1 12.0.0.2 2.2.2.2
  History:
    Tunnel:
      Time since created: 2 hours, 27 minutes
      Time since path change: 3 seconds
      Number of LSP IDs (Tun_Instances) used: 403
    Current LSP:
      Uptime: 8 seconds
      Selection: reoptimization
    Prior LSP:
      ID: path option 10 [382]
      Removal Trigger: reoptimization completed
R1#sh mpls  traffic-eng tunnels summ
Signalling Summary:
    LSP Tunnels Process:            running
    Passive LSP Listener:           running
    RSVP Process:                   running
    Forwarding:                     enabled
    Head: 2 interfaces, 1 active signalling attempts, 1 established
          43 activations, 42 deactivations
          0 SSO recovery attempts, 0 SSO recovered
    Midpoints: 0, Tails: 0
    Periodic reoptimization:        every 10 seconds, next in 4 seconds
    Periodic FRR Promotion:         Not Running
    Periodic auto-bw collection:    every 5 seconds, next in 2 seconds

R1#sh mpls traff tun tun0

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 5, type explicit R1_R2 (Basis for Setup, path weight 1)
    path option 10, type dynamic

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: explicit path option 5 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/0, implicit-null
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 403
    RSVP Path Info:
      My Address: 12.0.0.1  
      Explicit Route: 12.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 1 (TE)
    Explicit Route: 12.0.0.1 12.0.0.2 2.2.2.2
  History:
    Tunnel:
      Time since created: 2 hours, 28 minutes
      Time since path change: 57 seconds
      Number of LSP IDs (Tun_Instances) used: 403
    Current LSP:
      Uptime: 1 minutes, 2 seconds
      Selection: reoptimization
    Prior LSP:
      ID: path option 10 [382]
      Removal Trigger: reoptimization completed

R1#
R1#c
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#do sb
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        12.0.0.1        YES manual up                    up     
FastEthernet0/1        14.0.0.1        YES manual up                    up     
Loopback0              1.1.1.1         YES manual up                    up     
Tunnel0                1.1.1.1         YES TFTP   up                    up     
Tunnel1                1.1.1.1         YES TFTP   administratively down down   
R1(config)#int tun1
R1(config-if)#no shut
R1(config-if)#end
R1#
R1#
*May 18 00:32:03.811: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up
R1#
R1#
R1#
*May 18 00:32:05.003: %SYS-5-CONFIG_I: Configured from console by console
R1#sh mpls traff tun    

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 3)
    path option 5, type explicit R1_R2

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/1, 23
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 405
    RSVP Path Info:
      My Address: 14.0.0.1  
      Explicit Route: 14.0.0.4 34.0.0.4 34.0.0.3 23.0.0.3
                      23.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
  History:
    Tunnel:
      Time since created: 2 hours, 30 minutes
      Time since path change: 6 seconds
      Number of LSP IDs (Tun_Instances) used: 405
    Current LSP:
      Uptime: 6 seconds
    Prior LSP:
      ID: path option 5 [404]
      Removal Trigger: path error
      Last Error: PCALC:: Can’t use link 12.0.0.1 on node 1.1.1.1

Name: R1_t1                               (Tunnel1) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 1)
         
  Config Parameters:
    Bandwidth: 50000    kbps (Global)  Priority: 5  5   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 50000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/0, implicit-null
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 1, Tun_Instance 231
    RSVP Path Info:
      My Address: 12.0.0.1  
      Explicit Route: 12.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
  History:
    Tunnel:
      Time since created: 1 hours, 8 minutes
      Time since path change: 8 seconds
      Number of LSP IDs (Tun_Instances) used: 231
    Current LSP:
      Uptime: 8 seconds
    Prior LSP:
      ID: path option 10 [220]
      Removal Trigger: tunnel shutdown

QoS for AToM

April 16, 2010 at 12:48 am | Posted in MPLS, QoS | Leave a comment

Topology

Add R5 as a P router between R1 & R2 in the previous lab, so that we can monitor packets based on MPLS EXP bits.

R3 —— R1 —— R5 —— R2 —— R4

Configuration

 

R3#

class-map TELNET
 match protocol telnet

class-map ICMP
 match protocol icmp

class-map ANY
 match any
policy-map SET_COS

class TELNET
 set cos 5

class ICMP
 set cos 1

class ANY
 set cos 2

interface FastEthernet0/0.100
 encapsulation dot1Q 100
 ip address 34.0.0.3 255.255.255.0
 service-policy output SET_COS

R1#
class-map COS7
 match cos 7
class-map COS6
 match cos 6
class-map COS5
 match cos 5
class-map COS4
 match cos 4
class-map COS3
 match cos 3
class-map COS2
 match cos 2
class-map COS1
 match cos 1
class-map COS0
 match cos 0

policy-map ETHERNET_OVER_MPLS

class COS7
 set mpls experimental 7
class COS6
 set mpls experimental 6
class COS5
 set mpls experimental 5
class COS4
 set mpls experimental 4
class COS3
 set mpls experimental 3
class COS2
 set mpls experimental 2
class COS1
 set mpls experimental 1
class COS0
 set mpls experimental 0

!
interface FastEthernet0/1.100
 description Connect to R3 via VLAN 100
 encapsulation dot1Q 100
 service-policy input ETHERNET_OVER_MPLS
 no cdp enable
 xconnect 2.2.2.2 1000 pw-class AToM
R5#
no class-map match-all EXP7
no class-map match-all EXP6
no class-map match-all EXP5
no class-map match-all EXP4
no class-map match-all EXP3
no class-map match-all EXP2
no class-map match-all EXP1
no class-map match-all EXP0

class-map match-all EXP7
  match mpls experimental topmost 7
class-map match-all EXP6
  match mpls experimental topmost 6
class-map match-all EXP5
  match mpls experimental topmost 5
class-map match-all EXP4
  match mpls experimental topmost 4
class-map match-all EXP3
  match mpls experimental topmost 3
class-map match-all EXP2
  match mpls experimental topmost 2
class-map match-all EXP1
  match mpls experimental topmost 1
class-map match-all EXP0
  match mpls experimental topmost 0
no policy-map EXP_COUNTERS

policy-map EXP_COUNTERS
class EXP7
class EXP6
class EXP5
class EXP4
class EXP3
class EXP2
class EXP1
class EXP0
class class-default
int fa0/0
 service-policy input EXP_COUNTERS
 service-policy output EXP_COUNTERS

Verification

 
Rack1R3#ping 34.0.0.4 rep 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 34.0.0.4, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 8/32/84 ms
Rack1R3#telnet 34.0.0.4
Trying 34.0.0.4 … Open

Rack1R4>
Rack1R4>
Rack1R4>
Rack1R4>exit

[Connection to 34.0.0.4 closed by foreign host]
Rack1R3#telnet 34.0.0.4 80
Trying 34.0.0.4, 80 …
% Connection refused by remote host

Rack1R3#telnet 34.0.0.4 80
Trying 34.0.0.4, 80 …
% Connection refused by remote host

Rack1R3#
Rack1R3#
Rack1R3#sh policy-map interface
 FastEthernet0/0.100

  Service-policy output: SET_COS

    Class-map: TELNET (match-all)
      21 packets, 1350 bytes

      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol telnet
      QoS Set
        cos 5
          Packets marked 21

    Class-map: ICMP (match-all)
      100 packets, 11800 bytes

      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol icmp
      QoS Set
        cos 1
          Packets marked 100

    Class-map: ANY (match-all)
      2 packets, 128 bytes

      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      QoS Set
        cos 2
          Packets marked 2

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any

Rack1R1#sh policy-map interface

 FastEthernet0/1.100

  Service-policy input: ETHERNET_OVER_MPLS

    Class-map: COS7 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  7
      QoS Set
        mpls experimental imposition 7
           Packets marked 0

    Class-map: COS6 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  6
      QoS Set
        mpls experimental imposition 6
           Packets marked 0

    Class-map: COS5 (match-all)
      21 packets, 1350 bytes

      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  5
      QoS Set
        mpls experimental imposition 5
           Packets marked 21

    Class-map: COS4 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  4
      QoS Set
        mpls experimental imposition 4
           Packets marked 0

    Class-map: COS3 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  3
      QoS Set
        mpls experimental imposition 3
           Packets marked 0
    Class-map: COS2 (match-all)
      2 packets, 128 bytes

      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  2
      QoS Set
        mpls experimental imposition 2
           Packets marked 2

    Class-map: COS1 (match-all)
      100 packets, 11800 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  1
      QoS Set
        mpls experimental imposition 1
           Packets marked 100

    Class-map: COS0 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: cos  0
      QoS Set
        mpls experimental imposition 0

           Packets marked 0

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
Rack1R5#sh policy-map interface fa0/0 input

 FastEthernet0/0

  Service-policy input: EXP_COUNTERS

    Class-map: EXP7 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: mpls experimental topmost 7

    Class-map: EXP6 (match-all) ! ROUTING(?) & CONTROL TRAFFIC
      36 packets, 2780 bytes

      5 minute offered rate 0 bps
      Match: mpls experimental topmost 6

    Class-map: EXP5 (match-all) ! Telnet
      21 packets, 1518 bytes

      5 minute offered rate 0 bps
      Match: mpls experimental topmost 5

    Class-map: EXP4 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps

      Match: mpls experimental topmost 4

    Class-map: EXP3 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: mpls experimental topmost 3

    Class-map: EXP2 (match-all) ! TCP PORT 80 generated via telnet 34.0.0.4 80
      2 packets, 144 bytes

      5 minute offered rate 0 bps
      Match: mpls experimental topmost 2

    Class-map: EXP1 (match-all) ! Pings
      100 packets, 12600 bytes

      5 minute offered rate 0 bps
      Match: mpls experimental topmost 1

    Class-map: EXP0 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: mpls experimental topmost 0
    Class-map: class-default (match-any) ! Plain IP TRAFFIC (not MPLS)
      8 packets, 528 bytes

      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any

Reference

http://fengnet.com/book/IOS_MPLS/ch13lev1sec6.html

AToM: Frame PVC to VLAN

April 14, 2010 at 11:58 pm | Posted in Blogroll, MPLS, VPN | Leave a comment

 Topology

Fa0/0        Fa0/1   Fa0/0       Fa0/0   S1/0               S1/0
R3 -------------- R1 ---------------- R2 --------FR-------- R4
                 (PE)                (PE)

 

Configuration

R1#
mpls ldp router-id Loopback0
mpls label protocol ldp
!
pseudowire-class AToM
 encapsulation mpls
 interworking ip
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.0.0.1 255.255.255.0
 mpls ip

!
interface FastEthernet0/1
 no ip address
 no shut
!
interface FastEthernet0/1.100
 description Connect to R3 via VLAN 100
 encapsulation dot1Q 100
 no cdp enable
 xconnect 2.2.2.2 1000 pw-class AToM
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 12.0.0.1 0.0.0.0 area 0
!
ip classless
R2#
mpls ldp router-id Loopback0
mpls label protocol ldp
!
pseudowire-class AToM
 encapsulation mpls
 interworking ip
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.0.0.2 255.255.255.0
 mpls ip
!
!
interface Serial1/0
 description Connect to R4 (CE2) via Frame PVC 204
 no ip address
 encapsulation frame-relay
 no shutdown
!
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 12.0.0.2 0.0.0.0 area 0
!
!
!
connect FR-VLAN Serial1/0 204 l2transport
 xconnect 1.1.1.1 1000 pw-class AToM
 !
!
!
!
R3#

interface FastEthernet0/0
 description Connected to R1
 no ip address

!
interface FastEthernet0/0.100
 encapsulation dot1Q 100
 ip address 34.0.0.3 255.255.255.0
R4#

interface Serial1/0
 no ip address
 encapsulation frame-relay

!
interface Serial1/0.1 point-to-point
 ip address 34.0.0.4 255.255.255.0
 frame-relay interface-dlci 402

Verification

 

Rack1R1#sh mpls l2transport summary
Destination address: 2.2.2.2, total number of vc: 1
  0 unknown, 1 up, 0 down, 0 admin down, 0 recovering
  1 active vc on MPLS interface Fa0/0
Rack1R1#show mpls l2transport binding
  Destination Address: 2.2.2.2,  VC ID: 1000
    Local Label:  18
        Cbit: 1,    VC Type: IP,    GroupID: 0
        MTU: 1500,   Interface Desc: n/a
        VCCV Capabilities: None
    Remote Label: 17
        Cbit: 1,    VC Type: IP,    GroupID: 0
        MTU: 1500,   Interface Desc: n/a
        VCCV Capabilities: None

Rack1R1#sh mpls l2transport vc 1000 detail
Local interface: Fa0/1.100 up, line protocol up, Eth VLAN 100 up
  MPLS VC type is IP, interworking type is IP
  Destination address: 2.2.2.2, VC ID: 1000, VC status: up
    Output interface: Fa0/0, imposed label stack {17}
    Preferred path: not configured
    Default path: active
    Tunnel label: imp-null, next hop 12.0.0.2
  Create time: 00:16:34, last status change time: 00:15:20
  Signaling protocol: LDP, peer 2.2.2.2:0 up
    MPLS VC labels: local 18, remote 17
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  VC statistics:
    packet totals: receive 35, send 24
    byte totals:   receive 3500, send 2928
    packet drops:  receive 0, send 0
Rack1R2#sh mpls l2transport vc 1000 detail
Local interface: Se1/0 up, line protocol up, FR DLCI 204 up
  MPLS VC type is IP, interworking type is IP
  Destination address: 1.1.1.1, VC ID: 1000, VC status: up
    Output interface: Fa0/0, imposed label stack {18}
    Preferred path: not configured
    Default path: active
    Tunnel label: imp-null, next hop 12.0.0.1
  Create time: 00:23:41, last status change time: 00:15:52
  Signaling protocol: LDP, peer 1.1.1.1:0 up
    MPLS VC labels: local 17, remote 18
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  VC statistics:
    packet totals: receive 24, send 35
    byte totals:   receive 2400, send 4270
    packet drops:  receive 0, send 0

Rack1R3#ping 34.0.0.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 34.0.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/42/72 ms

Rack1R1#show mpls l2transport hw-capability interface fa0/1
Interface FastEthernet0/1

Transport type FR DLCI
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type ATM AAL5
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type ATM CELL
  Core functionality:
    MPLS label disposition supported
    Control word processing not supported
    Sequence number processing not supported
    VCCV Type 1 processing not supported
  Edge functionality:
    Not supported

Transport type Eth VLAN
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    MPLS label imposition supported
    Control word processing supported
    Sequence number processing not supported

Transport type Ethernet
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    MPLS label imposition supported
    Control word processing supported
    Sequence number processing not supported

Transport type HDLC
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type PPP
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type CEM
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type ATM VCC CELL
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type ATM VPC CELL
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type VFI
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Rack1R2#sh mpls l2transport hw-capability ?
  interface  Show MPLS L2 transport interface capability

Rack1R2#sh mpls l2transport hw-capability int
Rack1R2#sh mpls l2transport hw-capability interface atm2/0
Interface ATM2/0

Transport type FR DLCI
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type ATM AAL5
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type ATM CELL
  Core functionality:
    MPLS label disposition supported
    Control word processing not supported
    Sequence number processing not supported
    VCCV Type 1 processing not supported
  Edge functionality:
    Not supported

Transport type Eth VLAN
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type Ethernet
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type HDLC
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type PPP
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type CEM
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type ATM VCC CELL
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type ATM VPC CELL
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

Transport type VFI
  Core functionality:
    MPLS label disposition supported
    Control word processing supported
    Sequence number processing not supported
    VCCV Type 1 processing supported
  Edge functionality:
    Not supported

NOTE that MTU have to match. Otherwise, xconnect does not come up.

Rack1R2(config)#int s1/0
Rack1R2(config-if)#mtu ?
  <64-18000>  MTU size in bytes

Rack1R2(config-if)#mtu 1000
Rack1R2(config-if)#end
Rack1R2#
Rack1R2#
Rack1R2#
Rack1R2#
Rack1R2#
Rack1R2#sh mpls l2transport vc 1000 detail
Local interface: Se1/0 up, line protocol up, FR DLCI 204 up
  MPLS VC type is IP, interworking type is IP
  Destination address: 1.1.1.1, VC ID: 1000, VC status: down
    Output interface: if-?(0), imposed label stack {}
    Preferred path: not configured
    Default path: active
    Tunnel label: 0, next hop Invalid MOI
  Create time: 00:00:12, last status change time: 00:00:12
  Signaling protocol: LDP, peer 1.1.1.1:0 up
    MPLS VC labels: local 18, remote 16
    Group ID: local 0, remote 0
    MTU: local 1000, remote 1500
    Remote interface description: Connect to R3 via VLAN 100
  Sequencing: receive disabled, send disabled
  VC statistics:
    packet totals: receive 1952, send 1942
    byte totals:   receive 195200, send 236924
    packet drops:  receive 0, send 0

Ethernet over MPLS

February 11, 2010 at 4:33 pm | Posted in MPLS | Leave a comment

Topology

R7 --- R1(PE) --- R3(P) --- R2(PE) ---- R8

Default INE SP topology need to be modified to get R2 Fa0/0 connected to R8 Fa1/2 (instead of R7 Fa1/2)

Configuration

 

R1_PE1#
!
hostname R1_PE1
!
mpls ldp router-id Loopback0
!
!
interface Loopback0
 ip address 123.1.1.1 255.255.255.255
 no clns route-cache
!
interface FastEthernet0/0
 no ip address
 duplex full
 no clns route-cache
 no shut
!
interface FastEthernet0/0.100
 encapsulation dot1Q 100
 no cdp enable
 xconnect 123.1.1.3 123 encapsulation mpls
!
!
interface Serial2/1
 ip address 13.0.0.1 255.255.255.0
 mpls ip
 no shut
!
router ospf 100
 log-adjacency-changes
 network 13.0.0.1 0.0.0.0 area 0
 network 123.1.1.1 0.0.0.0 area 0
!
ip classless
!

R3_P#
!
hostname R3_P
mpls ldp router-id Loopback0
!
!
interface Loopback0
 ip address 123.1.1.3 255.255.255.255
!
interface Serial1/2
 ip address 13.0.0.3 255.255.255.0
 mpls ip
 no shut
!
interface Serial1/3
 ip address 23.0.0.3 255.255.255.0
 mpls ip
 no shut
!
router ospf 100
 log-adjacency-changes
 network 13.0.0.3 0.0.0.0 area 0
 network 23.0.0.3 0.0.0.0 area 0
 network 123.1.1.3 0.0.0.0 area 0
!

R2_PE2#sh run

hostname R2_PE2
!
mpls ldp router-id Loopback0

!
interface Loopback0
 ip address 123.1.1.2 255.255.255.255
 no clns route-cache
!
interface FastEthernet0/0
 no ip address
 duplex full
 no shut
!
interface FastEthernet0/0.100
 encapsulation dot1Q 100
 no cdp enable
 xconnect 123.1.1.3 123 encapsulation mpls
!
interface Serial2/1
 ip address 23.0.0.2 255.255.255.0
 mpls ip
 no shut
!
router ospf 100
 log-adjacency-changes
 network 23.0.0.2 0.0.0.0 area 0
 network 123.1.1.2 0.0.0.0 area 0
!
ip classless

Verification

R7#

vlan 100
!
interface Vlan100
 ip address 100.100.100.7 255.255.255.0

interface FastEthernet1/1
 description connected to R1 Fa0/0
 switchport mode trunk
 no shut

R8#

vlan 100
!
interface Vlan100
 ip address 100.100.100.8 255.255.255.0

interface FastEthernet1/2
 description connected to R2 Fa0/0
 switchport mode trunk
 no shut

R1_PE1#sh mpls l2transport vc

Local intf     Local circuit        Dest address    VC ID      Status   
-------------  -------------------- --------------- ---------- ----------
Fa0/0.100      Eth VLAN 100         123.1.1.2       100        UP       

R7#ping 100.100.100.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/91/152 ms

R7#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  100.100.100.7           -   cc06.2f08.0000  ARPA   Vlan100
Internet  100.100.100.8          43   cc07.2f10.0000  ARPA   Vlan100

MPLS VPN

February 11, 2010 at 2:29 pm | Posted in Blogroll, MPLS, VPN | Leave a comment

Topology

(CE1)R4 — R1 (PE) — R3 (P) — R2(PE) — R5 (CE2)

Configuration

R1-PE1#
!
hostname R1-PE1
!
!
ip vrf VPN_A
 rd 10:20
 route-target export 100:200
 route-target import 100:200
!
!
interface Loopback0
 ip address 100.100.100.1 255.255.255.255
!
!
interface Serial1/0
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip vrf forwarding VPN_A
 ip address 14.0.0.1 255.255.255.0
 frame-relay interface-dlci 104  
!
interface Serial1/1
 ip address 13.0.0.1 255.255.255.0
 mpls ip
!
router ospf 1
 network 13.0.0.1 0.0.0.0 area 0
 network 100.100.100.1 0.0.0.0 area 0
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 neighbor 100.100.100.2 remote-as 123
 neighbor 100.100.100.2 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 100.100.100.2 activate
  neighbor 100.100.100.2 send-community both
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  neighbor 14.0.0.4 remote-as 100
  neighbor 14.0.0.4 activate
  neighbor 14.0.0.4 as-override
  no synchronization
 exit-address-family

R3-P#sh run

hostname R3-P
!
!
!
interface Loopback0
 ip address 100.100.100.3 255.255.255.255
!
!
interface Serial1/2
 ip address 13.0.0.3 255.255.255.0
 mpls ip
!
interface Serial1/3
 ip address 23.0.0.3 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 13.0.0.3 0.0.0.0 area 0
 network 23.0.0.3 0.0.0.0 area 0
 network 100.100.100.3 0.0.0.0 area 0
 

R2-PE#sh run
!
hostname R2-PE
!
!
ip vrf VPN_A
 rd 10:20
 route-target export 100:200
 route-target import 100:200
!
!
interface Loopback0
 ip address 100.100.100.2 255.255.255.255
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip vrf forwarding VPN_A
 ip address 25.0.0.2 255.255.255.0
 frame-relay interface-dlci 205  
!
interface Serial1/1
 ip address 23.0.0.2 255.255.255.0
 mpls ip
 serial restart-delay 0
!
!
router ospf 1
 log-adjacency-changes
 network 23.0.0.2 0.0.0.0 area 0
 network 100.100.100.2 0.0.0.0 area 0
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 neighbor 100.100.100.1 remote-as 123
 neighbor 100.100.100.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 100.100.100.1 activate
  neighbor 100.100.100.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  neighbor 25.0.0.5 remote-as 100
  neighbor 25.0.0.5 activate
  neighbor 25.0.0.5 as-override
  no synchronization
 exit-address-family

 

R4-CE1#sh run

!
hostname R4-CE1
!
!
interface Loopback0
 ip address 10.4.4.1 255.255.255.0
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 14.0.0.4 255.255.255.0
 frame-relay interface-dlci 401  
!
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.4.4.0 mask 255.255.255.0
 network 14.0.0.0 mask 255.255.255.0
 neighbor 14.0.0.1 remote-as 123
 no auto-summary
!
R5-CE2#sh run
!
hostname R5-CE2
!
!
interface Loopback0
 ip address 10.5.5.1 255.255.255.0
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 25.0.0.5 255.255.255.0
 frame-relay interface-dlci 502  
!
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.5.5.0 mask 255.255.255.0
 network 25.0.0.0 mask 255.255.255.0
 neighbor 25.0.0.2 remote-as 123
 no auto-summary
!

Verification

 

R1-PE1#sh mpls ldp neighbor
    Peer LDP Ident: 100.100.100.3:0; Local LDP Ident 100.100.100.1:0
        TCP connection: 100.100.100.3.56829 - 100.100.100.1.646
        State: Oper; Msgs sent/rcvd: 233/233; Downstream
        Up time: 03:15:44
        LDP discovery sources:
          Serial1/1, Src IP addr: 13.0.0.3
        Addresses bound to peer LDP Ident:
          13.0.0.3        23.0.0.3        100.100.100.3  
R1-PE1#sh mpls ip binding  
  13.0.0.0/24
        in label:     imp-null 
        out label:    imp-null  lsr: 100.100.100.3:0
  23.0.0.0/24
        in label:     18       
        out label:    imp-null  lsr: 100.100.100.3:0  inuse
  100.100.100.1/32
        in label:     imp-null 
        out label:    16        lsr: 100.100.100.3:0
  100.100.100.2/32
        in label:     16       
        out label:    17        lsr: 100.100.100.3:0  inuse
  100.100.100.3/32
        in label:     17       
        out label:    imp-null  lsr: 100.100.100.3:0  inuse

R1-PE1#sh ip bgp vpnv4 vrf VPN_A ?
  A.B.C.D            IP prefix <network>/<length>, e.g., 35.0.0.0/8
  A.B.C.D            Network in the BGP routing table to display
  cidr-only          Display only routes with non-natural netmasks
  community          Display routes matching the communities
  community-list     Display routes matching the community-list
  dampening          Display detailed information about dampening
  extcommunity-list  Display routes matching the extcommunity-list
  filter-list        Display routes conforming to the filter-list
  inconsistent-as    Display only routes with inconsistent origin ASs
  labels             Display BGP labels for prefixes
  neighbors          Detailed information on TCP and BGP neighbor connections
  oer-paths          Display all oer controlled paths
  paths              Path information
  peer-group         Display information on peer-groups
  pending-prefixes   Display prefixes pending deletion
  prefix-list        Display routes matching the prefix-list
  quote-regexp       Display routes matching the AS path "regular expression"
  regexp             Display routes matching the AS path regular expression
  replication        Display replication status of update-group(s)
  rib-failure        Display bgp routes that failed to install in the routing
                     table (RIB)
  route-map          Display routes matching the route-map
  summary            Summary of BGP neighbor status
  update-group       Display information on update-groups
  |                  Output modifiers
  <cr>

R1-PE1#sh ip bgp vpnv4 vrf VPN_A
BGP table version is 19, local router ID is 100.100.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10:20 (default for vrf VPN_A)
*> 10.4.4.0/24      14.0.0.4                 0             0 100 i
*>i10.5.5.0/24      100.100.100.2            0    100      0 100 i
r> 14.0.0.0/24      14.0.0.4                 0             0 100 i
*>i25.0.0.0/24      100.100.100.2            0    100      0 100 i

R1-PE1#sh ip bgp vpnv4 vrf VPN_A 10.4.4.0/24
BGP routing table entry for 10:20:10.4.4.0/24, version 18
Paths: (1 available, best #1, table VPN_A)
  Advertised to update-groups:
     1        
  100
    14.0.0.4 from 14.0.0.4 (14.0.0.4)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Extended Community: RT:100:200
      mpls labels in/out 19/nolabel
R1-PE1#sh ip bgp vpnv4 vrf VPN_A 10.5.5.0/24
BGP routing table entry for 10:20:10.5.5.0/24, version 13
Paths: (1 available, best #1, table VPN_A)
  Advertised to update-groups:
     2        
  100
    100.100.100.2 (metric 129) from 100.100.100.2 (100.100.100.2)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:100:200
      mpls labels in/out nolabel/19
R1-PE1#sh mpls ip binding
  13.0.0.0/24
        in label:     imp-null 
        out label:    imp-null  lsr: 100.100.100.3:0
  23.0.0.0/24
        in label:     18       
        out label:    imp-null  lsr: 100.100.100.3:0  inuse
  100.100.100.1/32
        in label:     imp-null 
        out label:    16        lsr: 100.100.100.3:0
  100.100.100.2/32
        in label:     16       
        out label:    17        lsr: 100.100.100.3:0  inuse
  100.100.100.3/32
        in label:     17       
        out label:    imp-null  lsr: 100.100.100.3:0  inuse
R1-PE1#sh mpls ldp bindings detail
  tib entry: 13.0.0.0/24, rev 10
        local binding:  tag: imp-null
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: imp-null
  tib entry: 23.0.0.0/24, rev 8
        local binding:  tag: 18
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: imp-null
  tib entry: 100.100.100.1/32, rev 2
        local binding:  tag: imp-null
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: 16
  tib entry: 100.100.100.2/32, rev 4
        local binding:  tag: 16
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: 17
  tib entry: 100.100.100.3/32, rev 6
        local binding:  tag: 17
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: imp-null
Next Page »

Blog at WordPress.com.
Entries and comments feeds.

Follow

Get every new post delivered to your Inbox.