Debuging IP packets with ACL filter

April 28, 2007 at 12:22 pm | Posted in Blogroll | Leave a comment

ACL 101 is created just for the debuging purpose. It does not need to be applied on any interface! If we do not turn on the “debug ip packet detail 101” command, the ACL 101 does not record any “hits”. When we turn it on, it will record the number of hits via “show access-list 101” command

PE1#ping ip 165.87.1.2 source 165.87.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 165.87.1.2, timeout is 2 seconds:
Packet sent with a source address of 165.87.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
PE1#
*Mar  1 22:19:53.486: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:19:53.486: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:19:53.490: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:19:53.490: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:19:53.490: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:19:53.490: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:19:53.494: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:19:53.498: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:19:53.498: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:19:53.498: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:19:53.502: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:19:53.502: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:19:53.502: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:19:53.506: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:19:53.506: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:19:53.510: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:19:53.510: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:19:53.510: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:19:53.514: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:19:53.514: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
PE1#
PE1#
PE1#
PE1#debug ip packet detail 101
IP packet debugging is on (detailed) for access list 101
PE1#ping ip 165.87.1.2 source 165.87.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 165.87.1.2, timeout is 2 seconds:
Packet sent with a source address of 165.87.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
PE1#
*Mar  1 22:20:29.590: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:20:29.590: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:20:29.590:     ICMP type=8, code=0
*Mar  1 22:20:29.594: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:20:29.594: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:20:29.594:     ICMP type=0, code=0
*Mar  1 22:20:29.594: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:20:29.598: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:20:29.598:     ICMP type=8, code=0
*Mar  1 22:20:29.602: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:20:29.602: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:20:29.602:     ICMP type=0, code=0
*Mar  1 22:20:29.602: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:20:29.602: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:20:29.606:     ICMP type=8, code=0
*Mar  1 22:20:29.606: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:20:29.606: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:20:29.610:     ICMP type=0, code=0
*Mar  1 22:20:29.610: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:20:29.610: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:20:29.610:     ICMP type=8, code=0
*Mar  1 22:20:29.614: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:20:29.614: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:20:29.614:     ICMP type=0, code=0
*Mar  1 22:20:29.618: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:20:29.618: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:20:29.618:     ICMP type=8, code=0
*Mar  1 22:20:29.622: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:20:29.622: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:20:29.622:     ICMP type=0, code=0
PE1#
PE1#
PE1#ping 165.87.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 165.87.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
**** NO PACKETS match debugging criteria (ACL 101)
PE1#sh access-l 101
Extended IP access list 101
    10 permit icmp host 165.87.1.1 host 165.87.1.2 (20 matches)
    20 permit icmp host 165.87.1.2 host 165.87.1.1 (20 matches)

PE1#clear access-list ? 
  counters  Clear access list counters

PE1#clear access-list counters
PE1#sh access-l 101           
Extended IP access list 101
    10 permit icmp host 165.87.1.1 host 165.87.1.2
    20 permit icmp host 165.87.1.2 host 165.87.1.1
PE1#

PE1#ping ip 165.87.1.2 source 165.87.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 165.87.1.2, timeout is 2 seconds:
Packet sent with a source address of 165.87.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
PE1#sh access-l 101                    
Extended IP access list 101
    10 permit icmp host 165.87.1.1 host 165.87.1.2
    20 permit icmp host 165.87.1.2 host 165.87.1.1

PE1#debug ip packet detail 101
IP packet debugging is on (detailed) for access list 101
PE1#
PE1#
PE1#ping ip 165.87.1.2 source 165.87.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 165.87.1.2, timeout is 2 seconds:
Packet sent with a source address of 165.87.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
PE1#
*Mar  1 22:25:29.778: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:25:29.778: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:25:29.778:     ICMP type=8, code=0
*Mar  1 22:25:29.782: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:25:29.782: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:25:29.782:     ICMP type=0, code=0
*Mar  1 22:25:29.782: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:25:29.782: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:25:29.786:     ICMP type=8, code=0
*Mar  1 22:25:29.786: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:25:29.790: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:25:29.790:     ICMP type=0, code=0
*Mar  1 22:25:29.790: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:25:29.790: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:25:29.790:     ICMP type=8, code=0
*Mar  1 22:25:29.794: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:25:29.794: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:25:29.794:     ICMP type=0, code=0
*Mar  1 22:25:29.798: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:25:29.798: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:25:29.798:     ICMP type=8, code=0
*Mar  1 22:25:29.802: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:25:29.802: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:25:29.802:     ICMP type=0, code=0
*Mar  1 22:25:29.802: IP: tableid=0, s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), routed via FIB
*Mar  1 22:25:29.806: IP: s=165.87.1.1 (local), d=165.87.1.2 (Serial0/3), len 100, sending
*Mar  1 22:25:29.806:     ICMP type=8, code=0
*Mar  1 22:25:29.810: IP: tableid=0, s=165.87.1.2 (Serial0/3), d=165.87.1.1 (Loopback0), routed via RIB
*Mar  1 22:25:29.810: IP: s=165.87.1.2 (Serial0/3), d=165.87.1.1, len 100, rcvd 4
*Mar  1 22:25:29.810:     ICMP type=0, code=0
PE1#
PE1#
PE1#
PE1#sh access-list 101
Extended IP access list 101
    10 permit icmp host 165.87.1.1 host 165.87.1.2 (10 matches)
    20 permit icmp host 165.87.1.2 host 165.87.1.1 (10 matches)

Advertisements

IPv6 tunneling over IPv6

April 26, 2007 at 4:28 pm | Posted in IPv6 | Leave a comment

CE1#
ipv6 unicast-routing
!
!
interface FastEthernet0
 no ip address
 speed auto
 ipv6 address FEC0:0:0:1::2/64
 ipv6 rip attlab enable
!
PE1#
!
ipv6 unicast-routing
!
!
!
!
interface Loopback0
 ip address 165.87.1.1 255.255.255.255
!
interface Tunnel0
 description tunnel PE1 –> PE2
 no ip address
 ipv6 address FEC0:0:0:A::1/124
 ipv6 rip attlab enable
 tunnel source Serial0/2
 tunnel destination 32.29.1.6
 tunnel mode ipv6ip
!
interface FastEthernet0/0
 no ip address
 speed 10
 full-duplex
! this is required, to advertized the subnet via RIP
 ipv6 address FEC0:0:0:1::/64 eui-64

! this address is not required, if we do not want to ping from PE2 to PE1 FastEthernet
 ipv6 address FEC0:0:0:1::1/64
 ipv6 rip attlab enable
!
!
interface Serial0/2
 description WAN PE1 — PE2
 ip address 32.29.1.5 255.255.255.252
 clockrate 64000
!
!        
!
ipv6 router rip attlab
  no split-horizon
!
PE2#
!
ipv6 unicast-routing
!
interface Tunnel0
 description tunnel PE2 –> PE1
 no ip address
 ipv6 address FEC0:0:0:A::2/124
 ipv6 rip attlab enable
 tunnel source Serial0/2
 tunnel destination 32.29.1.5
 tunnel mode ipv6ip
!
interface FastEthernet0/0
 no ip address
 speed 10
 full-duplex
 ipv6 address FEC0:0:0:2::/64 eui-64
!
!
interface Serial0/2
 description WAN PE1 — PE2
 ip address 32.29.1.6 255.255.255.252
!
P1#
!
!
ipv6 unicast-routing
!
!
interface FastEthernet0/0
 no ip address
 speed 10
 full-duplex
 ipv6 address FEC0:0:0:2::2/64
 ipv6 rip attlab enable
!

CE1#sh ipv6 int
CE1#sh ipv6 interface fa0
FastEthernet0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::211:BBFF:FEB0:8F07
  Global unicast address(es):
    FEC0:0:0:1::2, subnet is FEC0:0:0:1::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF00:2
    FF02::1:FFB0:8F07
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.

CE1#sh ipv6 route
IPv6 Routing Table – 6 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
       U – Per-user Static route
       I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
       O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
       ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
L   FE80::/10 [0/0]
     via ::, Null0
C   FEC0:0:0:1::/64 [0/0]
     via ::, FastEthernet0
L   FEC0:0:0:1::2/128 [0/0]
     via ::, FastEthernet0
R   FEC0:0:0:2::/64 [120/3]
     via FE80::20B:5FFF:FE76:7280, FastEthernet0
R   FEC0:0:0:A::/124 [120/2]
     via FE80::20B:5FFF:FE76:7280, FastEthernet0
L   FF00::/8 [0/0]
     via ::, Null0
PE1#sh ipv6 interface fa0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::20B:5FFF:FE76:7280
  Global unicast address(es):
    FEC0:0:0:1::1, subnet is FEC0:0:0:1::/64
    FEC0::1:20B:5FFF:FE76:7280, subnet is FEC0:0:0:1::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF00:1
    FF02::1:FF76:7280
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
PE1#sh ipv6 interface tunnel0
Tunnel0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::201D:105
  Description: tunnel PE1 –> PE2
  Global unicast address(es):
    FEC0:0:0:A::1, subnet is FEC0:0:0:A::/124
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF00:1
    FF02::1:FF1D:105
  MTU is 1480 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.

PE2#sh ipv6 interface fa0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::214:F2FF:FE7F:AE60
  Global unicast address(es):
    FEC0::2:214:F2FF:FE7F:AE60, subnet is FEC0:0:0:2::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF7F:AE60
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
PE2#sh ipv6 interface tunnel0
Tunnel0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::201D:106
  Description: tunnel PE2 –> PE1
  Global unicast address(es):
    FEC0:0:0:A::2, subnet is FEC0:0:0:A::/124
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF00:2
    FF02::1:FF1D:106
  MTU is 1480 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
PE2#

P1#sh ipv6 interface fa0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::20B:5FFF:FE63:1620
  Global unicast address(es):
    FEC0:0:0:2::2, subnet is FEC0:0:0:2::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF00:2
    FF02::1:FF63:1620
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
P1#sh ipv6 route
IPv6 Routing Table – 6 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
       U – Per-user Static route
       I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea
L   FE80::/10 [0/0]
     via ::, Null0
R   FEC0:0:0:1::/64 [120/3]
     via FE80::214:F2FF:FE7F:AE60, FastEthernet0/0
L   FEC0:0:0:2::2/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet0/0
R   FEC0:0:0:A::/124 [120/2]
     via FE80::214:F2FF:FE7F:AE60, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0
CE1#traceroute ipv6 FEC0:0:0:2::2

Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::2

  1 FEC0:0:0:1::1 0 msec 0 msec 4 msec
  2 FEC0:0:0:A::2 28 msec 28 msec 28 msec
  3 FEC0:0:0:2::2 32 msec 28 msec 32 msec

CE1#debug ipv6 icmp
ICMP packet debugging is on
CE1#
CE1#
CE1#
CE1#traceroute ipv6 FEC0:0:0:2::2

Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::2

  1
ICMPv6: Received ICMPv6 packet from FEC0:0:0:1::1, type 3
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 135
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 136FEC0:0:0:1::1 0 msec 0 msec 4 msec
  2
ICMPv6: Received ICMPv6 packet from FEC0:0:0:1::1, type 3
ICMPv6: Received ICMPv6 packet from FEC0:0:0:1::1, type 3
ICMPv6: Received ICMPv6 packet from FEC0:0:0:A::2, type 3
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 135FEC0:0:0:A::2 28 msec 28 msec 28 msec
  3
ICMPv6: Received ICMPv6 packet from FEC0:0:0:A::2, type 3
ICMPv6: Received ICMPv6 packet from FEC0:0:0:A::2, type 3
ICMPv6: Received ICMPv6 packet from FEC0:0:0:2::2, type 1
ICMPv6: Received ICMP unreachable code 4 from FEC0:0:0:2::2
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 134FEC0:0:0:2::2 28 msec 28 msec 28 msec
CE1#
ICMPv6: Received ICMPv6 packet from FEC0:0:0:2::2, type 1
ICMPv6: Received ICMP unreachable code 4 from FEC0:0:0:2::2
ICMPv6: Received ICMPv6 packet from FEC0:0:0:2::2, type 1
ICMPv6: Received ICMP unreachable code 4 from FEC0:0:0:2::2
CE1#debug ipv6 packet
IPv6 unicast packet debugging is on
CE1#
CE1#
CE1#ping ipv6 FEC0:0:0:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/37/40 ms
CE1#
IPV6: source FE80::211:BBFF:FEB0:8F07 (local)
      dest FF02::9 (FastEthernet0)
      traffic class 224, flow 0x0, len 72+1428, prot 17, hops 255, originating
IPv6: Sending on FastEthernet0
IPv6: SAS picked source FEC0:0:0:1::2 for FEC0:0:0:2::2 (FastEthernet0)
IPv6: nexthop FE80::20B:5FFF:FE76:7280,
IPV6: source FEC0:0:0:1::2 (local)
      dest FEC0:0:0:2::2 (FastEthernet0)
      traffic class 0, flow 0x0, len 100+0, prot 58, hops 64, originating
IPv6: Sending on FastEthernet0
IPV6: source FEC0:0:0:2::2 (FastEthernet0)
      dest FEC0:0:0:1::2
      traffic class 0, flow 0x0, len 100+14, prot 58, hops 62, forward to ulp
IPv6: SAS picked source FEC0:0:0:1::2 for FEC0:0:0:2::2 (FastEthernet0)
IPv6: nexthop FE80::20B:5FFF:FE76:7280,
IPV6: source FEC0:0:0:1::2 (local)
      dest FEC0:0:0:2::2 (FastEthernet0)
      traffic class 0, flow 0x0, len 100+0, prot 58, hops 64, originating
IPv6: Sending on FastEthernet0
IPV6: source FEC0:0:0:2::2 (FastEthernet0)
      dest FEC0:0:0:1::2
      traffic class 0, flow 0x0, len 100+14, prot 58, hops 62, forward to ulp
IPv6: SAS picked source FEC0:0:0:1::2 for FEC0:0:0:2::2 (FastEthernet0)
IPv6: nexthop FE80::20B:5FFF:FE76:7280,
IPV6: source FEC0:0:0:1::2 (local)
      dest FEC0:0:0:2::2 (FastEthernet0)
      traffic class 0, flow 0x0, len 100+0, prot 58, hops 64, originating
IPv6: Sending on FastEthernet0
IPV6: source FEC0:0:0:2::2 (FastEthernet0)
      dest FEC0:0:0:1::2
      traffic class 0, flow 0x0, len 100+14, prot 58, hops 62, forward to ulp
IPv6: SAS picked source FEC0:0:0:1::2 for FEC0:0:0:2::2 (FastEthernet0)
IPv6: nexthop FE80::20B:5FFF:FE76:7280,
IPV6: source FEC0:0:0:1::2 (local)
      dest FEC0:0:0:2::2 (FastEthernet0)
      traffic class 0, flow 0x0, len 100+0, prot 58, hops 64, originating
IPv6: Sending on FastEthernet0
IPV6: source FEC0:0:0:2::2 (FastEthernet0)
      dest FEC0:0:0:1::2
      traffic class 0, flow 0x0, len 100+14, prot 58, hops 62, forward to ulp
IPv6: SAS picked source FEC0:0:0:1::2 for FEC0:0:0:2::2 (FastEthernet0)
IPv6: nexthop FE80::20B:5FFF:FE76:7280,
IPV6: source FEC0:0:0:1::2 (local)
    dest FEC0:0:0:2::2 (FastEthernet0)
      traffic class 0, flow 0x0, len 100+0, prot 58, hops 64, originating
IPv6: Sending on FastEthernet0
IPV6: source FEC0:0:0:2::2 (FastEthernet0)
      dest FEC0:0:0:1::2
      traffic class 0, flow 0x0, len 100+14, prot 58, hops 62, forward to ulp
IPV6: source FE80::211:BBFF:FEB0:8F07 (local)
      dest FF02::9 (FastEthernet0)
      traffic class 224, flow 0x0, len 72+1428, prot 17, hops 255, originating
IPv6: Sending on FastEthernet0

IPv6 BGP routing

April 25, 2007 at 1:48 pm | Posted in BGP, IPv6, Routing | 2 Comments

CE1#

ipv6 unicast-routing
!
!
interface Serial0
 no ip address
 ipv6 address 200A:0:0:10::2/124
 clockrate 4000000
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 200A:0:0:10::1 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor 200A:0:0:10::1 activate
 exit-address-family
!
PE1#
!
!
ipv6 unicast-routing
!
!
interface FastEthernet0/0
 no ip address
 speed 10
 full-duplex
 ipv6 address 200A:0:0:2::1/64
!
interface Serial0/0
 description IGP link
 no ip address
 ipv6 address 200A:0:0:1::1/124
 no fair-queue
!
interface Serial0/1
 description link to CE1
 no ip address
 ipv6 address 200A:0:0:10::1/124

!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 200A:0:0:2::2 remote-as 300
 neighbor 200A:0:0:10::2 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor 200A:0:0:2::2 activate
 neighbor 200A:0:0:10::2 activate
 network 200A:0:0:1::/124
 exit-address-family
!
P1#
!
ipv6 unicast-routing
!
!
interface FastEthernet0/0
 description P1 to PE1 (e-BGP)
 no ip address
 speed 10
 full-duplex
 ipv6 address 200A:0:0:2::2/64
!
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 neighbor 200A:0:0:2::1 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor 200A:0:0:2::1 activate
 exit-address-family

PE1#sh bgp ipv6 summary
BGP router identifier 165.87.1.1, local AS number 100
BGP table version is 2, main routing table version 2
1 network entries and 1 paths using 201 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
200A:0:0:2::2   4   300       5       6        2    0    0 00:01:15        0
200A:0:0:10::2  4   100       5       6        2    0    0 00:01:38        0
P1#sh bgp ipv6 summ
BGP router identifier 165.87.1.2, local AS number 300
BGP table version is 5, main routing table version 5
1 network entries and 1 paths using 201 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 2/1 prefixes, 2/1 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
200A:0:0:2::1   4   100      41      39        5    0    0 00:05:53        1
CE1#sh ip bgp summ
BGP router identifier 32.34.1.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
200A:0:0:10::1  4   100       9       8        0    0    0 00:04:12 (NoNeg)

CE1#sh ipv6 route
IPv6 Routing Table – 5 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
       U – Per-user Static route
       I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
       O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
       ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
B   200A:0:0:1::/124 [200/0]
     via 200A:0:0:10::1
C   200A:0:0:10::/124 [0/0]
     via ::, Serial0
L   200A:0:0:10::2/128 [0/0]
     via ::, Serial0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

CE1#sh bgp ipv6 unicast summary
BGP router identifier 32.34.1.1, local AS number 100
BGP table version is 4, main routing table version 4
1 network entries using 149 bytes of memory
1 path entries using 72 bytes of memory
2/1 BGP path/bestpath attribute entries using 232 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 453 total bytes of memory
BGP activity 2/1 prefixes, 2/1 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
200A:0:0:10::1  4   100      19      17        4    0    0 00:02:22        1
% NOTE: This command is deprecated. Please use ‘show bgp ipv6 unicast’

CE1#sh bgp ipv6 unicast
BGP table version is 4, local router ID is 32.34.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i200A:0:0:1::/124 200A:0:0:10::1           0    100      0 i
CE1#sh bgp ipv6 unicast neighbors
BGP neighbor is 200A:0:0:10::1,  remote AS 100, internal link
  BGP version 4, remote router ID 165.87.1.1
  BGP state = Established, up for 00:03:32
  Last read 00:00:32, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised
    Address family IPv6 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                0          1
    Keepalives:             6          6
    Route Refresh:          0          0
    Total:                  7          8
  Default minimum time between advertisement runs is 5 seconds

 For address family: IPv4 Unicast
  BGP table version 1, neighbor version 0/0
  Output queue sizes : 0 self, 0 replicated
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               —-       —-
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    ——–    ——-
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0

 For address family: IPv6 Unicast
  BGP table version 2, neighbor version 2/0
  Output queue sizes : 0 self, 0 replicated
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               —-       —-
    Prefixes Current:               0          1 (Consumes 72 bytes)
    Prefixes Total:                 0          1
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    ——–    ——-
    Bestpath from this peer:              1        n/a
    Total:                                1          0
  Number of NLRIs in the update sent: max 0, min 0

  Connections established 1; dropped 0
  Last reset never
Connection state is ESTAB, I/O status: 1, unread input bytes: 0       
Connection is ECN Disabled
Local host: 200A:0:0:10::2, Local port: 179
Foreign host: 200A:0:0:10::1, Foreign port: 11011

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x5537760):
Timer          Starts    Wakeups            Next
Retrans             6          0             0x0
TimeWait            0          0             0x0
AckHold             6          2             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 3514389540  snduna: 3514389708  sndnxt: 3514389708     sndwnd:  16217
irs:  559465704  rcvnxt:  559465949  rcvwnd:      16140  delrcvwnd:    244

SRTT: 165 ms, RTTO: 1172 ms, RTV: 1007 ms, KRTT: 0 ms
minRTT: 0 ms, maxRTT: 300 ms, ACK hold: 200 ms
Flags: passive open, nagle, gen tcbs
IP Precedence value : 6

Datagrams (max data segment is 1440 bytes):
Rcvd: 11 (out of order: 0), with data: 6, total data bytes: 244
Sent: 8 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 8, total data bytes: 495
 

IPv6 simple RIP routing

April 25, 2007 at 11:32 am | Posted in IPv6 | Leave a comment

PE1#
!
ipv6 unicast-routing
!
!
interface FastEthernet0/0
 no ip address
 speed 10
 full-duplex
 ipv6 address FEC0::/64 eui-64
 ipv6 address FEC0:0:0:1::/64 eui-64
 ipv6 address FEC0:0:0:2::/64 eui-64
 ipv6 enable
 ipv6 rip attlab enable
!        

ipv6 router rip attlab
  no split-horizon
!
!

P1#
!
ipv6 unicast-routing
!
!
interface FastEthernet0/0
 no ip address
 speed 10
 full-duplex
 ipv6 address FEC0::/64 eui-64
 ipv6 address FEC0:0:0:2::/64 eui-64
 ipv6 address FEC0:0:0:3::/64 eui-64
 ipv6 enable
 ipv6 rip attlab enable
!        

ipv6 router rip attlab
  no split-horizon
!

PE1#sh ipv6 int fa0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::20B:5FFF:FE76:7280
  Global unicast address(es):
    FEC0::20B:5FFF:FE76:7280, subnet is FEC0::/64
    FEC0::1:20B:5FFF:FE76:7280, subnet is FEC0:0:0:1::/64
    FEC0::2:20B:5FFF:FE76:7280, subnet is FEC0:0:0:2::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF76:7280
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
PE1#sh ipv
PE1#sh ipv6 route
IPv6 Routing Table – 9 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
       U – Per-user Static route
       I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea
L   FE80::/10 [0/0]
     via ::, Null0
L   FEC0::20B:5FFF:FE76:7280/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::1:20B:5FFF:FE76:7280/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:1::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::2:20B:5FFF:FE76:7280/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet0/0
R   FEC0:0:0:3::/64 [120/2]
     via FE80::20B:5FFF:FE63:1620, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0

P1#sh ipv6 int fa0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::20B:5FFF:FE63:1620
  Global unicast address(es):
    FEC0::20B:5FFF:FE63:1620, subnet is FEC0::/64
    FEC0::2:20B:5FFF:FE63:1620, subnet is FEC0:0:0:2::/64
    FEC0::3:20B:5FFF:FE63:1620, subnet is FEC0:0:0:3::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF63:1620
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for addresses.
P1#sh ipv6 route
IPv6 Routing Table – 9 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
       U – Per-user Static route
       I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea
L   FE80::/10 [0/0]
     via ::, Null0
L   FEC0::20B:5FFF:FE63:1620/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0::/64 [0/0]
     via ::, FastEthernet0/0
R   FEC0:0:0:1::/64 [120/2]
     via FE80::20B:5FFF:FE76:7280, FastEthernet0/0
L   FEC0::2:20B:5FFF:FE63:1620/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:2::/64 [0/0]
     via ::, FastEthernet0/0
L   FEC0::3:20B:5FFF:FE63:1620/128 [0/0]
     via ::, FastEthernet0/0
C   FEC0:0:0:3::/64 [0/0]
     via ::, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0

IPv6 Ping & Debug ICMP commands

April 25, 2007 at 11:29 am | Posted in IPv6 | Leave a comment

PE1#
!
ipv6 unicast-routing
!
interface FastEthernet0/0
 ip address 50.50.50.2 255.255.255.0
 speed 10
 full-duplex
 ipv6 enable

CE1#
!
ipv6 unicast-routing
!
!
interface FastEthernet0
 ip address 50.50.50.10 255.255.255.0
 speed 10
 full-duplex
 ipv6 enable

PE1#sh ipv6 nei
IPv6 Address                              Age Link-layer Addr State Interface
FE80::211:BBFF:FEB0:8F07                    0 0011.bbb0.8f07  STALE Fa0/0

PE1#sh deb
Generic IPv6:
  ICMP packet debugging is on
PE1#ping ipv6 FE80::211:BBFF:FEB0:8F07
Output Interface: fastethernet0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::211:BBFF:FEB0:8F07, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
PE1#
*Mar  1 05:07:23.594: ICMPv6: Sending echo request to FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.594: ICMPv6: Received ICMPv6 packet from FE80::211:BBFF:FEB0:8F07, type 135
*Mar  1 05:07:23.598: ICMPv6: Received ICMPv6 packet from FE80::211:BBFF:FEB0:8F07, type 129
*Mar  1 05:07:23.598: ICMPv6: Received echo reply from FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.598: ICMPv6: Sending echo request to FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.602: ICMPv6: Received ICMPv6 packet from FE80::211:BBFF:FEB0:8F07, type 129
*Mar  1 05:07:23.602: ICMPv6: Received echo reply from FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.602: ICMPv6: Sending echo request to FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.602: ICMPv6: Received ICMPv6 packet from FE80::211:BBFF:FEB0:8F07, type 129
*Mar  1 05:07:23.602: ICMPv6: Received echo reply from FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.606: ICMPv6: Sending echo request to FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.606: ICMPv6: Received ICMPv6 packet from FE80::211:BBFF:FEB0:8F07, type 129
*Mar  1 05:07:23.606: ICMPv6: Received echo reply from FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.606: ICMPv6: Sending echo request to FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:23.610: ICMPv6: Received ICMPv6 packet from FE80::211:BBFF:FEB0:8F07, type 129
*Mar  1 05:07:23.610: ICMPv6: Received echo reply from FE80::211:BBFF:FEB0:8F07
*Mar  1 05:07:28.594: ICMPv6: Received ICMPv6 packet from FE80::211:BBFF:FEB0:8F07, type 136

PE1#sh ipv6 nei
IPv6 Address                              Age Link-layer Addr State Interface
FE80::211:BBFF:FEB0:8F07                    0 0011.bbb0.8f07  REACH Fa0/0
CE1#sh ipv6 nei
IPv6 Address                              Age Link-layer Addr State Interface
FE80::20B:5FFF:FE76:7280                    2 000b.5f76.7280  STALE Fa0

CE1#debug ipv6 icmp
ICMP packet debugging is on
CE1#ping ipv6 FE80::20B:5FFF:FE76:7280
Output Interface: FastEthernet0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::20B:5FFF:FE76:7280, timeout is 2 seconds:
Packet sent with a source address of FE80::211:BBFF:FEB0:8F07
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
CE1#
ICMPv6: Sending echo request to FE80::20B:5FFF:FE76:7280
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 129
ICMPv6: Received echo reply from FE80::20B:5FFF:FE76:7280
ICMPv6: Sending echo request to FE80::20B:5FFF:FE76:7280
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 129
ICMPv6: Received echo reply from FE80::20B:5FFF:FE76:7280
ICMPv6: Sending echo request to FE80::20B:5FFF:FE76:7280
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 129
ICMPv6: Received echo reply from FE80::20B:5FFF:FE76:7280
ICMPv6: Sending echo request to FE80::20B:5FFF:FE76:7280
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 129
ICMPv6: Received echo reply from FE80::20B:5FFF:FE76:7280
ICMPv6: Sending echo request to FE80::20B:5FFF:FE76:7280
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 129
ICMPv6: Received echo reply from FE80::20B:5FFF:FE76:7280
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 136
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 135
ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE76:7280, type 134
CE1#sh ipv6 nei
IPv6 Address                              Age Link-layer Addr State Interface
FE80::20B:5FFF:FE76:7280                    0 000b.5f76.7280  REACH Fa0
Turn on IPv6 on another router P1
P1(config)#ipv6 unicast-routing
P1(config)#int fa0/0
P1(config-if)#ipv6 enable
PE1#debug ipv6 nd    
ICMP Neighbor Discovery events debugging is on
PE1#
*Mar  1 05:13:48.042: ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE63:1620, type 136
*Mar  1 05:13:48.042: ICMPv6-ND: Received NA for FE80::20B:5FFF:FE63:1620 on FastEthernet0/0 from FE80::20B:5FFF:FE63:1620
*Mar  1 05:13:51.042: ICMPv6: Received ICMPv6 packet from FE80::20B:5FFF:FE63:1620, type 134
*Mar  1 05:13:51.042: ICMPv6-ND: Received RA from FE80::20B:5FFF:FE63:1620 on FastEthernet0/0
*Mar  1 05:13:51.042: ICMPv6-ND: DELETE -> INCMP: FE80::20B:5FFF:FE63:1620
*Mar  1 05:13:51.042: ICMPv6-ND: INCMP -> STALE: FE80::20B:5FFF:FE63:1620
*Mar  1 05:14:14.254: ICMPv6-ND: Sending RA to FF02::1 on FastEthernet0/0
*Mar  1 05:14:14.254: ICMPv6-ND:     MTU = 1500
*Mar  1 05:14:27.114: ICMPv6: Received ICMPv6 packet from FE80::211:BBFF:FEB0:8F07, type 134
*Mar  1 05:14:27.114: ICMPv6-ND: Received RA from FE80::211:BBFF:FEB0:8F07 on FastEthernet0/0
PE1#
PE1#
PE1#sh ipv6 nei
IPv6 Address                              Age Link-layer Addr State Interface
FE80::20B:5FFF:FE63:1620                    0 000b.5f63.1620  STALE Fa0/0
FE80::211:BBFF:FEB0:8F07                    3 0011.bbb0.8f07  STALE Fa0/0

Extended Pings to verify MTU

April 20, 2007 at 12:42 pm | Posted in Blogroll | Leave a comment

PE1#ping
Protocol [ip]:
Target IP address: 165.87.1.3
Repeat count [5]: 1
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]:
Set DF bit in IP header? [no]: y
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: LSRTV
% No such option – “LSRTV”Loose, Strict, Record, Timestamp, Verbose[none]: R
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]: y
Sweep min size [76]: 1488
Sweep max size [18024]: 1508
Sweep interval [1]: 4
Type escape sequence to abort.
Sending 6, [1488..1508]-byte ICMP Echos to 165.87.1.3, timeout is 2 seconds:
Packet sent with the DF bit set
Packet has IP options:  Total option bytes= 39, padded length=40
 Record route: <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)

Reply to request 0 (28 ms) (size 1488).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (32.29.1.10)
   (32.29.1.13)
   (165.87.1.3)
   (32.29.1.14)
   (32.29.1.9)
   (32.29.1.10) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 1 (28 ms) (size 1492).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (32.29.1.10)
   (32.29.1.13)
   (165.87.1.3)
   (32.29.1.14)
   (32.29.1.9)
   (32.29.1.10) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 2 (28 ms) (size 1496).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (32.29.1.10)
   (32.29.1.13)
   (165.87.1.3)
   (32.29.1.14)
   (32.29.1.9)
   (32.29.1.10) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 3 (28 ms) (size 1500).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (32.29.1.10)
   (32.29.1.13)
   (165.87.1.3)
   (32.29.1.14)
   (32.29.1.9)
   (32.29.1.10) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Request 4 timed out (size 1504)
Request 5 timed out (size 1508)
Success rate is 66 percent (4/6), round-trip min/avg/max = 28/28/28 ms

Create a free website or blog at WordPress.com.
Entries and comments feeds.