Auto Install over Frame-Relay

August 6, 2008 at 3:34 pm | Posted in Blogroll, IP Services | 1 Comment

Doc CD navigation

  • Cisco IOS Configuration Fundamentals Configuration Guide, Release 12.4
  • Part 2: Configuration Using Setup and Autoinstall
  • Using AutoInstall to Remotely Configure Cisco Networking Devices
  • Configuration Examples for Using AutoInstall to Remotely Configure Cisco Networking Devices
  • Using AutoInstall to Set Up Devices Connected to WANs: Example
  • Frame-Relay WAN Connections
In this example, R5 is served as the AutoInstall router, R4 as frame-relay hub router, R1 as the staging router with the R5 config. R6 is the DNS server.
Auto Install over Frame-Relay

Auto Install over Frame-Relay diagram

To be able to configure the network to support auto install over frame-relay, one need to understand processes involved. Here’re the three steps network need to go through:

Step 1: AutoInstall router gets its IP address dynamically via one of the protocols

DHCP Servers (LAN)
SLARP Servers (HDLC)
BOOTP Servers (Frame Relay)

Note: The BOOTP server uses port 67 and the BOOTP client uses port 68

Step 2: AutoInstall router gets its hostname via DNS (UDP port 53)

Step 3: AutoInstall router download its full config from TFTP server (UDP port 69)

Configurations
R1#

hostname R1
!
!
!
interface FastEthernet0/0
ip address 155.1.146.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 155.1.146.4

tftp-server flash:r5-confg

R1#show flash | in r5
10   1321     r5-confg

R6#
!
hostname R6
!
ip host r5 155.1.0.5
ip dns server
!
!
interface FastEthernet0/0
ip address 155.1.146.6 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 155.1.146.4
!

R4#

!
hostname R4
!
!
ip name-server 155.1.146.6
!
interface FastEthernet0/0
ip address 155.1.146.4 255.255.255.0
!
interface Serial0/0
ip address 155.1.0.4 255.255.255.0
ip helper-address 155.1.146.1
ip helper-address 155.1.146.6
encapsulation frame-relay
frame-relay map ip 155.1.0.5 405 broadcast
no frame-relay inverse-arp
!

Debuging messages

Step 1: AutoInstall router gets its IP address dynamically via Bootp (UDP 67,68)

R4#
Aug  6 13:48:44.955: IP: s=0.0.0.0 (Serial0/0), d=255.255.255.255, len 328, rcvd 2
Aug  6 13:48:44.955:     UDP src=68, dst=67
Aug  6 13:48:44.955: IP: s=155.1.0.4 (local), d=155.1.0.5 (Serial0/0), len 328, sending
Aug  6 13:48:44.959:     UDP src=67, dst=68

Step 2: AutoInstall router gets its hostname via DNS (UDP port 53)

R6#
Aug  6 13:49:12.519: IP: tableid=0, s=155.1.0.5 (FastEthernet0/0), d=155.1.146.6 (FastEthernet0/0), routed via RIB
Aug  6 13:49:12.519: IP: s=155.1.0.5 (FastEthernet0/0), d=155.1.146.6 (FastEthernet0/0), len 68, rcvd 3
Aug  6 13:49:12.519:     UDP src=57326, dst=53
Aug  6 13:49:12.519: DNS: Finished processing query (id#1) in 0.000 secs
Aug  6 13:49:12.523: IP: tableid=0, s=155.1.146.6 (local), d=155.1.0.5 (FastEthernet0/0), routed via FIB
Aug  6 13:49:12.523: IP: s=155.1.146.6 (local), d=155.1.0.5 (FastEthernet0/0), len 84, sending
Aug  6 13:49:12.523:     UDP src=53, dst=57326

Step 3: AutoInstall router download its full config from TFTP server (UDP port 69)

R1#
Aug  6 13:49:18.867: IP: tableid=0, s=155.1.0.5 (FastEthernet0/0), d=155.1.146.1 (FastEthernet0/0), routed via RIB
Aug  6 13:49:18.867: IP: s=155.1.0.5 (FastEthernet0/0), d=155.1.146.1 (FastEthernet0/0), len 50, rcvd 3
Aug  6 13:49:18.867:     UDP src=51301, dst=69
Aug  6 13:49:18.871: TFTP: Server request for port 51301, socket_id 0x8553A09C for process 68
Aug  6 13:49:18.871: TFTP: read request from host 155.1.0.5(51301) via FastEthernet0/0
Aug  6 13:49:18.871: TFTP: Looking for network-confg
Aug  6 13:49:18.871: TFTP: Sending error 1 No such file
Aug  6 13:49:18.871: IP: tableid=0, s=155.1.146.1 (local), d=155.1.0.5 (FastEthernet0/0), routed via FIB
Aug  6 13:49:18.871: IP: s=155.1.146.1 (local), d=155.1.0.5 (FastEthernet0/0), len 45, sending
Aug  6 13:49:18.875:     UDP src=50389, dst=51301
Aug  6 13:49:20.907: IP: tableid=0, s=155.1.0.5 (FastEthernet0/0), d=155.1.146.1 (FastEthernet0/0), routed via RIB
Aug  6 13:49:20.907: IP: s=155.1.0.5 (FastEthernet0/0), d=155.1.146.1 (FastEthernet0/0), len 49, rcvd 3
Aug  6 13:49:20.907:     UDP src=54836, dst=69
Aug  6 13:49:20.911: TFTP: Server request for port 54836, socket_id 0x85186FB8 for process 68
Aug  6 13:49:20.911: TFTP: read request from host 155.1.0.5(54836) via FastEthernet0/0
Aug  6 13:49:20.911: TFTP: Looking for cisconet.cfg
Aug  6 13:49:20.915: TFTP: Sending error 1 No such file

Aug  6 13:49:21.019:     UDP src=52405, dst=69
Aug  6 13:49:21.023: TFTP: Server request for port 52405, socket_id 0x8553A09C for process 68
Aug  6 13:49:21.023: TFTP: read request from host 155.1.0.5(52405) via FastEthernet0/0
Aug  6 13:49:21.023: TFTP: Looking for r5-confg
Aug  6 13:49:21.023: TFTP: Opened flash:r5-confg, fd 0, size 1321 for process 68
Aug  6 13:49:21.027: TFTP: Sending block 1 (retry 0), socket_id 0x8553A09C

Advertisements

1 Comment »

RSS feed for comments on this post. TrackBack URI

  1. […] I also found a pretty good blog post on autoinstall […]


Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Create a free website or blog at WordPress.com.
Entries and comments feeds.

%d bloggers like this: