Ethernet over MPLS

February 11, 2010 at 4:33 pm | Posted in MPLS | Leave a comment

Topology

R7 --- R1(PE) --- R3(P) --- R2(PE) ---- R8

Default INE SP topology need to be modified to get R2 Fa0/0 connected to R8 Fa1/2 (instead of R7 Fa1/2)

Configuration

 

R1_PE1#
!
hostname R1_PE1
!
mpls ldp router-id Loopback0
!
!
interface Loopback0
 ip address 123.1.1.1 255.255.255.255
 no clns route-cache
!
interface FastEthernet0/0
 no ip address
 duplex full
 no clns route-cache
 no shut
!
interface FastEthernet0/0.100
 encapsulation dot1Q 100
 no cdp enable
 xconnect 123.1.1.3 123 encapsulation mpls
!
!
interface Serial2/1
 ip address 13.0.0.1 255.255.255.0
 mpls ip
 no shut
!
router ospf 100
 log-adjacency-changes
 network 13.0.0.1 0.0.0.0 area 0
 network 123.1.1.1 0.0.0.0 area 0
!
ip classless
!

R3_P#
!
hostname R3_P
mpls ldp router-id Loopback0
!
!
interface Loopback0
 ip address 123.1.1.3 255.255.255.255
!
interface Serial1/2
 ip address 13.0.0.3 255.255.255.0
 mpls ip
 no shut
!
interface Serial1/3
 ip address 23.0.0.3 255.255.255.0
 mpls ip
 no shut
!
router ospf 100
 log-adjacency-changes
 network 13.0.0.3 0.0.0.0 area 0
 network 23.0.0.3 0.0.0.0 area 0
 network 123.1.1.3 0.0.0.0 area 0
!

R2_PE2#sh run

hostname R2_PE2
!
mpls ldp router-id Loopback0

!
interface Loopback0
 ip address 123.1.1.2 255.255.255.255
 no clns route-cache
!
interface FastEthernet0/0
 no ip address
 duplex full
 no shut
!
interface FastEthernet0/0.100
 encapsulation dot1Q 100
 no cdp enable
 xconnect 123.1.1.3 123 encapsulation mpls
!
interface Serial2/1
 ip address 23.0.0.2 255.255.255.0
 mpls ip
 no shut
!
router ospf 100
 log-adjacency-changes
 network 23.0.0.2 0.0.0.0 area 0
 network 123.1.1.2 0.0.0.0 area 0
!
ip classless

Verification

R7#

vlan 100
!
interface Vlan100
 ip address 100.100.100.7 255.255.255.0

interface FastEthernet1/1
 description connected to R1 Fa0/0
 switchport mode trunk
 no shut

R8#

vlan 100
!
interface Vlan100
 ip address 100.100.100.8 255.255.255.0

interface FastEthernet1/2
 description connected to R2 Fa0/0
 switchport mode trunk
 no shut

R1_PE1#sh mpls l2transport vc

Local intf     Local circuit        Dest address    VC ID      Status   
-------------  -------------------- --------------- ---------- ----------
Fa0/0.100      Eth VLAN 100         123.1.1.2       100        UP       

R7#ping 100.100.100.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/91/152 ms

R7#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  100.100.100.7           -   cc06.2f08.0000  ARPA   Vlan100
Internet  100.100.100.8          43   cc07.2f10.0000  ARPA   Vlan100

MPLS VPN

February 11, 2010 at 2:29 pm | Posted in Blogroll, MPLS, VPN | Leave a comment

Topology

(CE1)R4 — R1 (PE) — R3 (P) — R2(PE) — R5 (CE2)

Configuration

R1-PE1#
!
hostname R1-PE1
!
!
ip vrf VPN_A
 rd 10:20
 route-target export 100:200
 route-target import 100:200
!
!
interface Loopback0
 ip address 100.100.100.1 255.255.255.255
!
!
interface Serial1/0
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip vrf forwarding VPN_A
 ip address 14.0.0.1 255.255.255.0
 frame-relay interface-dlci 104  
!
interface Serial1/1
 ip address 13.0.0.1 255.255.255.0
 mpls ip
!
router ospf 1
 network 13.0.0.1 0.0.0.0 area 0
 network 100.100.100.1 0.0.0.0 area 0
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 neighbor 100.100.100.2 remote-as 123
 neighbor 100.100.100.2 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 100.100.100.2 activate
  neighbor 100.100.100.2 send-community both
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  neighbor 14.0.0.4 remote-as 100
  neighbor 14.0.0.4 activate
  neighbor 14.0.0.4 as-override
  no synchronization
 exit-address-family

R3-P#sh run

hostname R3-P
!
!
!
interface Loopback0
 ip address 100.100.100.3 255.255.255.255
!
!
interface Serial1/2
 ip address 13.0.0.3 255.255.255.0
 mpls ip
!
interface Serial1/3
 ip address 23.0.0.3 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 13.0.0.3 0.0.0.0 area 0
 network 23.0.0.3 0.0.0.0 area 0
 network 100.100.100.3 0.0.0.0 area 0
 

R2-PE#sh run
!
hostname R2-PE
!
!
ip vrf VPN_A
 rd 10:20
 route-target export 100:200
 route-target import 100:200
!
!
interface Loopback0
 ip address 100.100.100.2 255.255.255.255
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip vrf forwarding VPN_A
 ip address 25.0.0.2 255.255.255.0
 frame-relay interface-dlci 205  
!
interface Serial1/1
 ip address 23.0.0.2 255.255.255.0
 mpls ip
 serial restart-delay 0
!
!
router ospf 1
 log-adjacency-changes
 network 23.0.0.2 0.0.0.0 area 0
 network 100.100.100.2 0.0.0.0 area 0
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 neighbor 100.100.100.1 remote-as 123
 neighbor 100.100.100.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 100.100.100.1 activate
  neighbor 100.100.100.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  neighbor 25.0.0.5 remote-as 100
  neighbor 25.0.0.5 activate
  neighbor 25.0.0.5 as-override
  no synchronization
 exit-address-family

 

R4-CE1#sh run

!
hostname R4-CE1
!
!
interface Loopback0
 ip address 10.4.4.1 255.255.255.0
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 14.0.0.4 255.255.255.0
 frame-relay interface-dlci 401  
!
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.4.4.0 mask 255.255.255.0
 network 14.0.0.0 mask 255.255.255.0
 neighbor 14.0.0.1 remote-as 123
 no auto-summary
!
R5-CE2#sh run
!
hostname R5-CE2
!
!
interface Loopback0
 ip address 10.5.5.1 255.255.255.0
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 25.0.0.5 255.255.255.0
 frame-relay interface-dlci 502  
!
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.5.5.0 mask 255.255.255.0
 network 25.0.0.0 mask 255.255.255.0
 neighbor 25.0.0.2 remote-as 123
 no auto-summary
!

Verification

 

R1-PE1#sh mpls ldp neighbor
    Peer LDP Ident: 100.100.100.3:0; Local LDP Ident 100.100.100.1:0
        TCP connection: 100.100.100.3.56829 - 100.100.100.1.646
        State: Oper; Msgs sent/rcvd: 233/233; Downstream
        Up time: 03:15:44
        LDP discovery sources:
          Serial1/1, Src IP addr: 13.0.0.3
        Addresses bound to peer LDP Ident:
          13.0.0.3        23.0.0.3        100.100.100.3  
R1-PE1#sh mpls ip binding  
  13.0.0.0/24
        in label:     imp-null 
        out label:    imp-null  lsr: 100.100.100.3:0
  23.0.0.0/24
        in label:     18       
        out label:    imp-null  lsr: 100.100.100.3:0  inuse
  100.100.100.1/32
        in label:     imp-null 
        out label:    16        lsr: 100.100.100.3:0
  100.100.100.2/32
        in label:     16       
        out label:    17        lsr: 100.100.100.3:0  inuse
  100.100.100.3/32
        in label:     17       
        out label:    imp-null  lsr: 100.100.100.3:0  inuse

R1-PE1#sh ip bgp vpnv4 vrf VPN_A ?
  A.B.C.D            IP prefix <network>/<length>, e.g., 35.0.0.0/8
  A.B.C.D            Network in the BGP routing table to display
  cidr-only          Display only routes with non-natural netmasks
  community          Display routes matching the communities
  community-list     Display routes matching the community-list
  dampening          Display detailed information about dampening
  extcommunity-list  Display routes matching the extcommunity-list
  filter-list        Display routes conforming to the filter-list
  inconsistent-as    Display only routes with inconsistent origin ASs
  labels             Display BGP labels for prefixes
  neighbors          Detailed information on TCP and BGP neighbor connections
  oer-paths          Display all oer controlled paths
  paths              Path information
  peer-group         Display information on peer-groups
  pending-prefixes   Display prefixes pending deletion
  prefix-list        Display routes matching the prefix-list
  quote-regexp       Display routes matching the AS path "regular expression"
  regexp             Display routes matching the AS path regular expression
  replication        Display replication status of update-group(s)
  rib-failure        Display bgp routes that failed to install in the routing
                     table (RIB)
  route-map          Display routes matching the route-map
  summary            Summary of BGP neighbor status
  update-group       Display information on update-groups
  |                  Output modifiers
  <cr>

R1-PE1#sh ip bgp vpnv4 vrf VPN_A
BGP table version is 19, local router ID is 100.100.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10:20 (default for vrf VPN_A)
*> 10.4.4.0/24      14.0.0.4                 0             0 100 i
*>i10.5.5.0/24      100.100.100.2            0    100      0 100 i
r> 14.0.0.0/24      14.0.0.4                 0             0 100 i
*>i25.0.0.0/24      100.100.100.2            0    100      0 100 i

R1-PE1#sh ip bgp vpnv4 vrf VPN_A 10.4.4.0/24
BGP routing table entry for 10:20:10.4.4.0/24, version 18
Paths: (1 available, best #1, table VPN_A)
  Advertised to update-groups:
     1        
  100
    14.0.0.4 from 14.0.0.4 (14.0.0.4)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Extended Community: RT:100:200
      mpls labels in/out 19/nolabel
R1-PE1#sh ip bgp vpnv4 vrf VPN_A 10.5.5.0/24
BGP routing table entry for 10:20:10.5.5.0/24, version 13
Paths: (1 available, best #1, table VPN_A)
  Advertised to update-groups:
     2        
  100
    100.100.100.2 (metric 129) from 100.100.100.2 (100.100.100.2)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:100:200
      mpls labels in/out nolabel/19
R1-PE1#sh mpls ip binding
  13.0.0.0/24
        in label:     imp-null 
        out label:    imp-null  lsr: 100.100.100.3:0
  23.0.0.0/24
        in label:     18       
        out label:    imp-null  lsr: 100.100.100.3:0  inuse
  100.100.100.1/32
        in label:     imp-null 
        out label:    16        lsr: 100.100.100.3:0
  100.100.100.2/32
        in label:     16       
        out label:    17        lsr: 100.100.100.3:0  inuse
  100.100.100.3/32
        in label:     17       
        out label:    imp-null  lsr: 100.100.100.3:0  inuse
R1-PE1#sh mpls ldp bindings detail
  tib entry: 13.0.0.0/24, rev 10
        local binding:  tag: imp-null
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: imp-null
  tib entry: 23.0.0.0/24, rev 8
        local binding:  tag: 18
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: imp-null
  tib entry: 100.100.100.1/32, rev 2
        local binding:  tag: imp-null
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: 16
  tib entry: 100.100.100.2/32, rev 4
        local binding:  tag: 16
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: 17
  tib entry: 100.100.100.3/32, rev 6
        local binding:  tag: 17
          Advertised to:
          100.100.100.3:0       
        remote binding: tsr: 100.100.100.3:0, tag: imp-null

Blog at WordPress.com.
Entries and comments feeds.