TE tunnel placement via explicit & dynamic paths

May 18, 2010 at 1:35 am | Posted in Blogroll, MPLS, Traffic Engineering | Leave a comment

R1#sh run
Building configuration…

Current configuration : 2645 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip source-route
ip cef
!
!
!
!
!
!        
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng reoptimize timers frequency 10
mpls traffic-eng reoptimize timers delay installation 5
mpls traffic-eng auto-bw timers frequency 5
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 6 6
 tunnel mpls traffic-eng bandwidth 55000
 tunnel mpls traffic-eng path-option 5 explicit name R1_R2
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 5 5
 tunnel mpls traffic-eng bandwidth 50000
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.0.0.1 255.255.255.0
 speed auto
 duplex auto
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth 90000 90000
!
interface FastEthernet0/1
 ip address 14.0.0.1 255.255.255.0
 speed auto
 duplex auto
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth 90000 90000
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 12.0.0.1 0.0.0.0 area 0
 network 14.0.0.1 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
ip explicit-path name R1_R4_R3_R2 enable
 next-address 14.0.0.4
 next-address 34.0.0.3
 next-address 23.0.0.2
!
ip explicit-path name R1_R2 enable
 next-address 12.0.0.2
!
R1(config)#mpls traffic-eng auto-bw timers frequency ?
  <1-604800>  seconds between auto-bw

R1(config)#mpls traffic-eng reoptimize events link-up

R1(config)#mpls traffic-eng reoptimize timers delay installation ?
  <0-3600>  seconds to delay replacement of tunnel LSP

R1(config)#mpls traffic-eng reoptimize timers delay installation 5
R1(config)#mpls traffic-eng reoptimize timers frequency ?
  <0-604800>  seconds between reoptimizations (0 disables reoptimization)

R1(config)#mpls traffic-eng reoptimize timers frequency 10
R1#

interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 6 6
 tunnel mpls traffic-eng bandwidth 50000
 tunnel mpls traffic-eng path-option 5 explicit name R1_R2 lockdown
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 5 5
 tunnel mpls traffic-eng bandwidth 50000
 tunnel mpls traffic-eng path-option 10 dynamic
ip explicit-path name R1_R4_R3_R2 enable
 next-address 14.0.0.4
 next-address 34.0.0.3
 next-address 23.0.0.2

ip explicit-path name R1_R2 enable
 next-address 12.0.0.2

R1#sh mpls traffic-eng tunnels summary
Signalling Summary:
    LSP Tunnels Process:            running
    Passive LSP Listener:           running
    RSVP Process:                   running
    Forwarding:                     enabled
    Head: 2 interfaces, 2 active signalling attempts, 2 established
          34 activations, 32 deactivations
          0 SSO recovery attempts, 0 SSO recovered
    Midpoints: 0, Tails: 0
    Periodic reoptimization:        every 10 seconds, next in 1 seconds
    Periodic FRR Promotion:         Not Running
    Periodic auto-bw collection:    every 5 seconds, next in 2 seconds

R1#sh mpls traffic-eng tunnels tun0   

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 3)

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/1, 22
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 281
    RSVP Path Info:
      My Address: 14.0.0.1  
      Explicit Route: 14.0.0.4 34.0.0.4 34.0.0.3 23.0.0.3
                      23.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 1 (TE)
    Explicit Route: 12.0.0.1 12.0.0.2 2.2.2.2
  History:
    Tunnel:
      Time since created: 2 hours, 16 minutes
      Time since path change: 6 minutes, 50 seconds
      Number of LSP IDs (Tun_Instances) used: 281
    Current LSP:
      Uptime: 6 minutes, 50 seconds
    Prior LSP:
      ID: path option 10 [280]
      Removal Trigger: path error
R1#sh mpls traffic-eng tunnels tun1

Name: R1_t1                               (Tunnel1) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 1)

  Config Parameters:
    Bandwidth: 50000    kbps (Global)  Priority: 5  5   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 50000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/0, implicit-null
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 1, Tun_Instance 132
    RSVP Path Info:
      My Address: 12.0.0.1  
      Explicit Route: 12.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 1 (TE)
    Explicit Route: 12.0.0.1 12.0.0.2 2.2.2.2
  History:
    Tunnel:
      Time since created: 54 minutes, 44 seconds
      Time since path change: 25 minutes, 57 seconds
      Number of LSP IDs (Tun_Instances) used: 132
    Current LSP:
      Uptime: 6 minutes, 54 seconds
      Selection: reoptimization
    Prior LSP:
      ID: path option 10 [39]
      Removal Trigger: configuration changed
R1#c
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int tun1
R1(config-if)#shut
R1(config-if)#end
R1#
R1#
R1#
R1#sh mpls  traffic-eng tunnels tun0

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 3)
    path option 5 reoptimization in progress

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/1, 22
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 382
    RSVP Path Info:
      My Address: 14.0.0.1  
      Explicit Route: 14.0.0.4 34.0.0.4 34.0.0.3 23.0.0.3
                      23.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 1 (TE)
    Explicit Route: 12.0.0.1 12.0.0.2 2.2.2.2
  History:
    Tunnel:
      Time since created: 2 hours, 27 minutes
      Time since path change: 3 seconds
      Number of LSP IDs (Tun_Instances) used: 403
    Current LSP:
      Uptime: 8 seconds
      Selection: reoptimization
    Prior LSP:
      ID: path option 10 [382]
      Removal Trigger: reoptimization completed
R1#sh mpls  traffic-eng tunnels summ
Signalling Summary:
    LSP Tunnels Process:            running
    Passive LSP Listener:           running
    RSVP Process:                   running
    Forwarding:                     enabled
    Head: 2 interfaces, 1 active signalling attempts, 1 established
          43 activations, 42 deactivations
          0 SSO recovery attempts, 0 SSO recovered
    Midpoints: 0, Tails: 0
    Periodic reoptimization:        every 10 seconds, next in 4 seconds
    Periodic FRR Promotion:         Not Running
    Periodic auto-bw collection:    every 5 seconds, next in 2 seconds

R1#sh mpls traff tun tun0

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 5, type explicit R1_R2 (Basis for Setup, path weight 1)
    path option 10, type dynamic

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: explicit path option 5 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/0, implicit-null
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 403
    RSVP Path Info:
      My Address: 12.0.0.1  
      Explicit Route: 12.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 1 (TE)
    Explicit Route: 12.0.0.1 12.0.0.2 2.2.2.2
  History:
    Tunnel:
      Time since created: 2 hours, 28 minutes
      Time since path change: 57 seconds
      Number of LSP IDs (Tun_Instances) used: 403
    Current LSP:
      Uptime: 1 minutes, 2 seconds
      Selection: reoptimization
    Prior LSP:
      ID: path option 10 [382]
      Removal Trigger: reoptimization completed

R1#
R1#c
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#do sb
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        12.0.0.1        YES manual up                    up     
FastEthernet0/1        14.0.0.1        YES manual up                    up     
Loopback0              1.1.1.1         YES manual up                    up     
Tunnel0                1.1.1.1         YES TFTP   up                    up     
Tunnel1                1.1.1.1         YES TFTP   administratively down down   
R1(config)#int tun1
R1(config-if)#no shut
R1(config-if)#end
R1#
R1#
*May 18 00:32:03.811: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up
R1#
R1#
R1#
*May 18 00:32:05.003: %SYS-5-CONFIG_I: Configured from console by console
R1#sh mpls traff tun    

Name: R1_t0                               (Tunnel0) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 3)
    path option 5, type explicit R1_R2

  Config Parameters:
    Bandwidth: 55000    kbps (Global)  Priority: 6  6   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 55000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/1, 23
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 0, Tun_Instance 405
    RSVP Path Info:
      My Address: 14.0.0.1  
      Explicit Route: 14.0.0.4 34.0.0.4 34.0.0.3 23.0.0.3
                      23.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=55000 kbits, burst=1000 bytes, peak rate=55000 kbits
  History:
    Tunnel:
      Time since created: 2 hours, 30 minutes
      Time since path change: 6 seconds
      Number of LSP IDs (Tun_Instances) used: 405
    Current LSP:
      Uptime: 6 seconds
    Prior LSP:
      ID: path option 5 [404]
      Removal Trigger: path error
      Last Error: PCALC:: Can’t use link 12.0.0.1 on node 1.1.1.1

Name: R1_t1                               (Tunnel1) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 1)
         
  Config Parameters:
    Bandwidth: 50000    kbps (Global)  Priority: 5  5   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 50000    bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: dynamic path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  InLabel  :  –
  OutLabel : FastEthernet0/0, implicit-null
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 1, Tun_Instance 231
    RSVP Path Info:
      My Address: 12.0.0.1  
      Explicit Route: 12.0.0.2 2.2.2.2
      Record   Route:   NONE
      Tspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=50000 kbits, burst=1000 bytes, peak rate=50000 kbits
  History:
    Tunnel:
      Time since created: 1 hours, 8 minutes
      Time since path change: 8 seconds
      Number of LSP IDs (Tun_Instances) used: 231
    Current LSP:
      Uptime: 8 seconds
    Prior LSP:
      ID: path option 10 [220]
      Removal Trigger: tunnel shutdown

Traffic Engineering – a simple configuration

December 10, 2006 at 11:46 pm | Posted in Blogroll, MPLS, Traffic Engineering | Leave a comment

MPLS TE configuration

  

hostname PE1
!
mpls traffic-eng tunnels
!
interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 192.168.1.33
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth  50
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Loopback0
 ip address 192.168.1.17 255.255.255.255
!
interface Serial0/3
 ip address 192.168.1.49 255.255.255.240
 mpls traffic-eng tunnels
 tag-switching ip
 clockrate 64000
 ip rsvp bandwidth 100 100
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0


!**************************************************


hostname P1
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 192.168.1.81 255.255.255.255
!
interface Serial0/0
 ip address 192.168.1.50 255.255.255.240
 mpls traffic-eng tunnels
 tag-switching ip
 ip rsvp bandwidth 100 100
!
interface Serial0/1
 ip address 192.168.1.66 255.255.255.240
 mpls traffic-eng tunnels
 tag-switching ip
 ip rsvp bandwidth 100 100
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0


!**************************************************


hostname PE2
!
mpls traffic-eng tunnels
interface Loopback0
 ip address 192.168.1.33 255.255.255.255
!
interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 192.168.1.17
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth  50
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Serial0/3
 ip address 192.168.1.65 255.255.255.240
 mpls traffic-eng tunnels
 tag-switching ip
 clockrate 64000
 ip rsvp bandwidth 100 100
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0



!**************************************************


PE1#sh mpls traffic-eng tunnels summary 
Signalling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Head: 1 interfaces, 1 active signalling attempts, 1 established
          1 activations, 0 deactivations
    Midpoints: 0, Tails: 1
    Periodic reoptimization:        every 3600 seconds, next in 3298 seconds
    Periodic auto-bw collection:    disabled


PE1#sh mpls traffic-eng tunnels Tunnel0

Name: PE1_t0                              (Tunnel0) Destination: 192.168.1.33
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 128)
  Config Parameters:
    Bandwidth: 50       kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 50       bw-based
    auto-bw: disabled

  InLabel  :  - 
  OutLabel : Serial0/3, 19
  RSVP Signalling Info:
       Src 192.168.1.17, Dst 192.168.1.33, Tun_Id 0, Tun_Instance 120
    RSVP Path Info:
      My Address: 192.168.1.17   
      Explicit Route: 192.168.1.50 192.168.1.65 192.168.1.33 
      Record Route:  NONE
      Tspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
    RSVP Resv Info:
      Record Route:  NONE
      Fspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 128 (TE)
    Explicit Route: 192.168.1.50 192.168.1.65 192.168.1.33 
  History:
    Tunnel:
      Time since created: 59 minutes, 10 seconds
      Time since path change: 3 minutes, 49 seconds
    Current LSP:
      Uptime: 3 minutes, 49 seconds

PE1#show mpls traffic-eng tunnels

Name: PE1_t0                              (Tunnel0) Destination: 192.168.1.33
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected

    path option 10, type dynamic (Basis for Setup, path weight 1064)

  Config Parameters:
    Bandwidth: 50       kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 50       bw-based
    auto-bw: disabled

  InLabel  :  - 
  OutLabel : Serial0/3, 19
  RSVP Signalling Info:
       Src 192.168.1.17, Dst 192.168.1.33, Tun_Id 0, Tun_Instance 120
    RSVP Path Info:
      My Address: 192.168.1.17   
      Explicit Route: 192.168.1.50 192.168.1.65 192.168.1.33 
      Record Route:  NONE
      Tspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
    RSVP Resv Info:
      Record Route:  NONE
      Fspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
  History:
    Tunnel:
      Time since created: 1 hours, 4 minutes
      Time since path change: 8 minutes, 48 seconds
    Current LSP:
      Uptime: 8 minutes, 48 seconds

LSP Tunnel PE2_t0 is signalled, connection is up
  InLabel  : Serial0/3, implicit-null
  OutLabel :  - 
  RSVP Signalling Info:
       Src 192.168.1.33, Dst 192.168.1.17, Tun_Id 0, Tun_Instance 69
    RSVP Path Info:
      My Address: 192.168.1.17   
      Explicit Route:  NONE
      Record Route:  NONE
      Tspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
    RSVP Resv Info:
      Record Route:  NONE
      Fspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits



PE1#show ip rsvp interface
interface    allocated  i/f max  flow max sub max 
Se0/3        50K        100K     100K     0 

PE1#show mpls traffic-eng topology 192.168.1.33

IGP Id: 192.168.1.33, MPLS TE Id:192.168.1.33 Router Node  id 2
      link[0 ]:Nbr IGP Id: 192.168.1.81, nbr_node_id:3, gen:6
          frag_id 0, Intf Address:192.168.1.65, Nbr Intf Address:192.168.1.66
          TE metric:64, IGP metric:64, attribute_flags:0x0
          physical_bw: 1544 (kbps), max_reservable_bw_global: 100 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool       Sub Pool
               Total Allocated   Reservable        Reservable
               BW (kbps)         BW (kbps)         BW (kbps)
               ---------------   -----------       ----------
        bw[0]:            0              100                0
        bw[1]:            0              100                0
        bw[2]:            0              100                0
        bw[3]:            0              100                0
        bw[4]:            0              100                0
        bw[5]:            0              100                0
        bw[6]:            0              100                0
        bw[7]:           50               50                0

Show MPLS label stack

December 10, 2006 at 6:35 pm | Posted in Blogroll, MPLS, Traffic Engineering, VPN | Leave a comment

Bellow outputs are for VPN scenario

 
PE1#sh mpls forwarding-table vrf Customer_A 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
19     Untagged    10.1.1.16/28[V]   0          Se0/1      point2point 
20     Untagged    10.1.1.49/32[V]   0          Se0/1      point2point 
21     Aggregate   150.1.1.16/28[V]  0 
PE1#sh mpls forwarding-table vrf Customer_A 150.1.2.16 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
None   16          150.1.2.16/28     0          Se0/3      point2point 
        MAC/Encaps=4/12, MRU=1496, Tag Stack{16 20} 
        0F008847 0001000000014000 
        No output feature configured 
    Per-packet load-sharing 
PE1#sh mpls forwarding-table vrf Customer_B 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
22     Untagged    10.2.1.16/28[V]   0          Se0/0      point2point 
23     Untagged    10.2.1.49/32[V]   0          Se0/0      point2point 
24     Aggregate   150.1.1.32/28[V]  0       

PE1#sh mpls forwarding-table vrf Customer_B 150.1.2.32 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
None   16          150.1.2.32/28     0          Se0/3      point2point 
        MAC/Encaps=4/12, MRU=1496, Tag Stack{16 16} 
        0F008847 0001000000010000 
        No output feature configured 
    Per-packet load-sharing  

PE1#sh mpls forwarding-table 192.168.1.33 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
18     16          192.168.1.33/32   0          Se0/3      point2point 
        MAC/Encaps=4/8, MRU=1500, Tag Stack{16} 
        0F008847 00010000 
        No output feature configured 
    Per-packet load-sharing  

In the above scenario the first label, 16, is for the loopback address of the router PE2, second (bottom) label 20 and 16 are for identifying VPN Customer_A and Customer_B respectively.

In the below scenario, MPLS is used for Traffic Engineering purpose.

7200a#show mpls forwarding 13.13.13.13 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
45     12326       13.13.13.13/32    0          PO3/0      point2point 
        MAC/Encaps=4/8, MTU=4470, Tag Stack{12326} 
        FF030281 03026000 
        No output feature configured 
    Per-destination load-sharing, slots: 0 2 4 6 8 10 12 14 
       43          13.13.13.13/32    0          Tu1        point2point 
        MAC/Encaps=4/12, MTU=4466, Tag Stack{12335 43}, via PO3/0 
        FF030281 0302F0000002B000 
        No output feature configured 
    Per-destination load-sharing, slots: 1 3 5 7 9 11 13 15       

Create a free website or blog at WordPress.com.
Entries and comments feeds.