Show LDP Label Information Base (LIB) or TIB

December 31, 2006 at 6:19 pm | Posted in Blogroll | Leave a comment

P1#sh tag-switching tdp ?
  bindings    Show the TDP Tag Information Base (TIB))
  discovery   Display sources for locally generated TDP Discovery Hello PDUs
  neighbor    Display TDP neighbor information
  parameters  Display TDP configuration parameters
 
P1#sh tag-switching tdp bindings
  tib entry: 50.50.50.0/24, rev 2
        local binding:  tag: imp-null
        remote binding: tsr: 192.168.1.33:0, tag: imp-null
        remote binding: tsr: 192.168.1.17:0, tag: imp-null
  tib entry: 192.168.1.17/32, rev 18
        local binding:  tag: 17
        remote binding: tsr: 192.168.1.33:0, tag: 24
        remote binding: tsr: 192.168.1.17:0, tag: imp-null
  tib entry: 192.168.1.33/32, rev 10
        local binding:  tag: 16
        remote binding: tsr: 192.168.1.33:0, tag: imp-null
        remote binding: tsr: 192.168.1.17:0, tag: 18
  tib entry: 192.168.1.48/28, rev 16
        local binding:  tag: imp-null
        remote binding: tsr: 192.168.1.33:0, tag: 23
        remote binding: tsr: 192.168.1.17:0, tag: imp-null
  tib entry: 192.168.1.64/28, rev 8
        local binding:  tag: imp-null
        remote binding: tsr: 192.168.1.33:0, tag: imp-null
        remote binding: tsr: 192.168.1.17:0, tag: 17
  tib entry: 192.168.1.81/32, rev 4
        local binding:  tag: imp-null
        remote binding: tsr: 192.168.1.33:0, tag: 19
        remote binding: tsr: 192.168.1.17:0, tag: 16
P1#sh mpls ldp ?
  backoff     LDP session setup backoff table
  bindings    Show the LDP Label Information Base (LIB))
  discovery   Display sources for locally generated LDP Discovery Hello PDUs
  neighbor    Display LDP neighbor information
  parameters  Display LDP configuration parameters

P1#sh mpls ldp bindings
  tib entry: 50.50.50.0/24, rev 2
        local binding:  tag: imp-null
        remote binding: tsr: 192.168.1.33:0, tag: imp-null
        remote binding: tsr: 192.168.1.17:0, tag: imp-null
  tib entry: 192.168.1.17/32, rev 18
        local binding:  tag: 17
        remote binding: tsr: 192.168.1.33:0, tag: 24
        remote binding: tsr: 192.168.1.17:0, tag: imp-null
  tib entry: 192.168.1.33/32, rev 10
        local binding:  tag: 16
        remote binding: tsr: 192.168.1.33:0, tag: imp-null
        remote binding: tsr: 192.168.1.17:0, tag: 18
  tib entry: 192.168.1.48/28, rev 16
        local binding:  tag: imp-null
        remote binding: tsr: 192.168.1.33:0, tag: 23
        remote binding: tsr: 192.168.1.17:0, tag: imp-null
  tib entry: 192.168.1.64/28, rev 8
        local binding:  tag: imp-null
        remote binding: tsr: 192.168.1.33:0, tag: imp-null
        remote binding: tsr: 192.168.1.17:0, tag: 17
  tib entry: 192.168.1.81/32, rev 4
        local binding:  tag: imp-null
        remote binding: tsr: 192.168.1.33:0, tag: 19
        remote binding: tsr: 192.168.1.17:0, tag: 16

Advertisements

Traffic Engineering – a simple configuration

December 10, 2006 at 11:46 pm | Posted in Blogroll, MPLS, Traffic Engineering | Leave a comment

MPLS TE configuration

  

hostname PE1
!
mpls traffic-eng tunnels
!
interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 192.168.1.33
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth  50
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Loopback0
 ip address 192.168.1.17 255.255.255.255
!
interface Serial0/3
 ip address 192.168.1.49 255.255.255.240
 mpls traffic-eng tunnels
 tag-switching ip
 clockrate 64000
 ip rsvp bandwidth 100 100
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0


!**************************************************


hostname P1
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 192.168.1.81 255.255.255.255
!
interface Serial0/0
 ip address 192.168.1.50 255.255.255.240
 mpls traffic-eng tunnels
 tag-switching ip
 ip rsvp bandwidth 100 100
!
interface Serial0/1
 ip address 192.168.1.66 255.255.255.240
 mpls traffic-eng tunnels
 tag-switching ip
 ip rsvp bandwidth 100 100
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0


!**************************************************


hostname PE2
!
mpls traffic-eng tunnels
interface Loopback0
 ip address 192.168.1.33 255.255.255.255
!
interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 192.168.1.17
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth  50
 tunnel mpls traffic-eng path-option 10 dynamic
!
interface Serial0/3
 ip address 192.168.1.65 255.255.255.240
 mpls traffic-eng tunnels
 tag-switching ip
 clockrate 64000
 ip rsvp bandwidth 100 100
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0



!**************************************************


PE1#sh mpls traffic-eng tunnels summary 
Signalling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Head: 1 interfaces, 1 active signalling attempts, 1 established
          1 activations, 0 deactivations
    Midpoints: 0, Tails: 1
    Periodic reoptimization:        every 3600 seconds, next in 3298 seconds
    Periodic auto-bw collection:    disabled


PE1#sh mpls traffic-eng tunnels Tunnel0

Name: PE1_t0                              (Tunnel0) Destination: 192.168.1.33
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type dynamic (Basis for Setup, path weight 128)
  Config Parameters:
    Bandwidth: 50       kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 50       bw-based
    auto-bw: disabled

  InLabel  :  - 
  OutLabel : Serial0/3, 19
  RSVP Signalling Info:
       Src 192.168.1.17, Dst 192.168.1.33, Tun_Id 0, Tun_Instance 120
    RSVP Path Info:
      My Address: 192.168.1.17   
      Explicit Route: 192.168.1.50 192.168.1.65 192.168.1.33 
      Record Route:  NONE
      Tspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
    RSVP Resv Info:
      Record Route:  NONE
      Fspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 128 (TE)
    Explicit Route: 192.168.1.50 192.168.1.65 192.168.1.33 
  History:
    Tunnel:
      Time since created: 59 minutes, 10 seconds
      Time since path change: 3 minutes, 49 seconds
    Current LSP:
      Uptime: 3 minutes, 49 seconds

PE1#show mpls traffic-eng tunnels

Name: PE1_t0                              (Tunnel0) Destination: 192.168.1.33
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected

    path option 10, type dynamic (Basis for Setup, path weight 1064)

  Config Parameters:
    Bandwidth: 50       kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 50       bw-based
    auto-bw: disabled

  InLabel  :  - 
  OutLabel : Serial0/3, 19
  RSVP Signalling Info:
       Src 192.168.1.17, Dst 192.168.1.33, Tun_Id 0, Tun_Instance 120
    RSVP Path Info:
      My Address: 192.168.1.17   
      Explicit Route: 192.168.1.50 192.168.1.65 192.168.1.33 
      Record Route:  NONE
      Tspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
    RSVP Resv Info:
      Record Route:  NONE
      Fspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
  History:
    Tunnel:
      Time since created: 1 hours, 4 minutes
      Time since path change: 8 minutes, 48 seconds
    Current LSP:
      Uptime: 8 minutes, 48 seconds

LSP Tunnel PE2_t0 is signalled, connection is up
  InLabel  : Serial0/3, implicit-null
  OutLabel :  - 
  RSVP Signalling Info:
       Src 192.168.1.33, Dst 192.168.1.17, Tun_Id 0, Tun_Instance 69
    RSVP Path Info:
      My Address: 192.168.1.17   
      Explicit Route:  NONE
      Record Route:  NONE
      Tspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits
    RSVP Resv Info:
      Record Route:  NONE
      Fspec: ave rate=50 kbits, burst=1000 bytes, peak rate=50 kbits



PE1#show ip rsvp interface
interface    allocated  i/f max  flow max sub max 
Se0/3        50K        100K     100K     0 

PE1#show mpls traffic-eng topology 192.168.1.33

IGP Id: 192.168.1.33, MPLS TE Id:192.168.1.33 Router Node  id 2
      link[0 ]:Nbr IGP Id: 192.168.1.81, nbr_node_id:3, gen:6
          frag_id 0, Intf Address:192.168.1.65, Nbr Intf Address:192.168.1.66
          TE metric:64, IGP metric:64, attribute_flags:0x0
          physical_bw: 1544 (kbps), max_reservable_bw_global: 100 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool       Sub Pool
               Total Allocated   Reservable        Reservable
               BW (kbps)         BW (kbps)         BW (kbps)
               ---------------   -----------       ----------
        bw[0]:            0              100                0
        bw[1]:            0              100                0
        bw[2]:            0              100                0
        bw[3]:            0              100                0
        bw[4]:            0              100                0
        bw[5]:            0              100                0
        bw[6]:            0              100                0
        bw[7]:           50               50                0

Show MPLS label stack

December 10, 2006 at 6:35 pm | Posted in Blogroll, MPLS, Traffic Engineering, VPN | Leave a comment

Bellow outputs are for VPN scenario

 
PE1#sh mpls forwarding-table vrf Customer_A 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
19     Untagged    10.1.1.16/28[V]   0          Se0/1      point2point 
20     Untagged    10.1.1.49/32[V]   0          Se0/1      point2point 
21     Aggregate   150.1.1.16/28[V]  0 
PE1#sh mpls forwarding-table vrf Customer_A 150.1.2.16 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
None   16          150.1.2.16/28     0          Se0/3      point2point 
        MAC/Encaps=4/12, MRU=1496, Tag Stack{16 20} 
        0F008847 0001000000014000 
        No output feature configured 
    Per-packet load-sharing 
PE1#sh mpls forwarding-table vrf Customer_B 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
22     Untagged    10.2.1.16/28[V]   0          Se0/0      point2point 
23     Untagged    10.2.1.49/32[V]   0          Se0/0      point2point 
24     Aggregate   150.1.1.32/28[V]  0       

PE1#sh mpls forwarding-table vrf Customer_B 150.1.2.32 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
None   16          150.1.2.32/28     0          Se0/3      point2point 
        MAC/Encaps=4/12, MRU=1496, Tag Stack{16 16} 
        0F008847 0001000000010000 
        No output feature configured 
    Per-packet load-sharing  

PE1#sh mpls forwarding-table 192.168.1.33 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
18     16          192.168.1.33/32   0          Se0/3      point2point 
        MAC/Encaps=4/8, MRU=1500, Tag Stack{16} 
        0F008847 00010000 
        No output feature configured 
    Per-packet load-sharing  

In the above scenario the first label, 16, is for the loopback address of the router PE2, second (bottom) label 20 and 16 are for identifying VPN Customer_A and Customer_B respectively.

In the below scenario, MPLS is used for Traffic Engineering purpose.

7200a#show mpls forwarding 13.13.13.13 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop 
tag    tag or VC   or Tunnel Id      switched   interface 
45     12326       13.13.13.13/32    0          PO3/0      point2point 
        MAC/Encaps=4/8, MTU=4470, Tag Stack{12326} 
        FF030281 03026000 
        No output feature configured 
    Per-destination load-sharing, slots: 0 2 4 6 8 10 12 14 
       43          13.13.13.13/32    0          Tu1        point2point 
        MAC/Encaps=4/12, MTU=4466, Tag Stack{12335 43}, via PO3/0 
        FF030281 0302F0000002B000 
        No output feature configured 
    Per-destination load-sharing, slots: 1 3 5 7 9 11 13 15       

Create a free website or blog at WordPress.com.
Entries and comments feeds.