VoIP Terminologies

May 27, 2007 at 8:20 pm | Posted in VoIP | Leave a comment

MLTS – Multiline Telephone System
PSAP – Public Safety Answering Point
LEC – Local Exchange Carrier
ANI – Automatic Number Identification
ALI – Automatic Location Identification

Dynamic ANI: ISDN-PRI, and CAMA
CAMA – Centralized Automatic Message Accounting
CPN – Calling Party Number

Static ANI: POTS line
ERL – Emergencey Response Location
AMIS – Audio Messaging Interchange Specification
SMDI – Station Message Detail Interface – the interface whereby a voice-mail system notifies a PBX to turn on/off the

message waiting indicator.

VAD – Voice Activity Detection
SID – Silence Insertion Descriptor

Network Alternate Route Selection (NARS, UDP, CDP)
RAS – Registration, Admission, and Status (RAS) H.225

Advertisements

H.323 Gatekeeper function

May 27, 2007 at 8:19 pm | Posted in VoIP | 2 Comments
http://www.iec.org/online/tutorials/h323/topic02.html  

The H.323 standard specifies four kinds of components, which, when networked together, provide the point-to-point and point-to-multipoint multimedia-communication services:

  • terminals
  • gateways
  • gatekeepers
  • multipoint control units (MCUs)

Gatekeepers

A gatekeeper can be considered the brain of the H.323 network. It is the focal point for all calls within the H.323 network. Although they are not required, gatekeepers provide important services such as addressing, authorization and authentication of terminals and gateways; bandwidth management; accounting; billing; and charging. Gatekeepers may also provide call-routing services.

Fax Passthough mode

May 22, 2007 at 7:26 pm | Posted in VoIP | Leave a comment
http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide_chapter09186a00800b5dd6.html

Information About Fax Pass-Through

Fax pass-through takes place when incoming T.30 fax data is not demodulated or compressed for its transit through the packet network. The two endpoints (fax machines or modems) communicate directly to each other over a transparent IP connection. The gateway does not distinguish fax calls from voice calls.

On detection of a fax tone on an established VoIP call, the gateways switch into fax pass-through mode by suspending the voice codec and loading the pass-through parameters for the duration of the fax session. This process, called upspeeding, changes the bandwidth needed for the call to the equivalent of G.711.

With pass-through, the fax traffic is carried between the two gateways in RTP packets using an uncompressed format resembling the G.711 codec. This method of transporting fax traffic takes a constant 64-kbps (payload) stream plus its IP overhead end-to-end for the duration of the call. IP overhead is 16 kbps for normal voice traffic, but when switching to pass-through, the packetization period is reduced from 20 ms to 10 ms, which means that half as much data can be put into each frame. The result is that you need twice as many frames and twice as much IP overhead. For pass-through, the total bandwidth is 64 plus 32 kbps, for a total of 96 kbps. For normal voice traffic, total bandwidth is 64 plus 16 kbps, for a total of 80 kbps.

Border Gateway Protocol Attributes

May 9, 2007 at 10:53 pm | Posted in BGP, Routing | Leave a comment

http://www.cramsession.com/articles/files/border-gateway-protocol-a-982003-1304.asp

Whether you are planning on taking the Building Scalable Cisco Networks (BSCN) or the Building Scalable Cisco Internetworks (BSCI) exam on the path to the CCNP certification, you are going to have to know BGP. For some reason, I have always had a hard time remembering the BGP attributes. This article is dedicated to the better understanding of BGP attributes.

A BGP attribute, or path attribute, is a metric used to describe the characteristics of a BGP path. Attributes are contained in update messages passed between BGP peers to advertise routes. There are four categories of BGP attributes. These are:

1) Well-known Mandatory
2) Well-known Discretionary
3) Optional Transitive
4) Optional Non-transitive

Optional transitive attributes may also be marked as partial.

Well-known attributes are attributes that all BGP implementations must recognize and are propagated to all BGP neighbors. Mandatory well-known attributes must appear in the route description. Discretionary attributes do not have to appear in the route description (they are not mandatory).

Optional attributes may not be supported by all BGP implementations. The transitive bit determines if an optional attribute is passed to BGP neighbors. If an optional attribute is transitive and not supported by a neighbor, it is passed and marked as partial. If it is non-transitive, a neighbor that does not implement the attribute deletes it.

The attributes that are commonly used in the Cisco Implementation of BGP are as follows:

WELL-KNOWN, MANDATORY

AS-path: A list of the Autonomous Systems (AS) numbers that a route passes through to reach the destination. As the update passes through an AS the AS number is inserted at the beginning of the list. The AS-path attribute has a reverse-order list of AS passed through to get to the destination.

Next-hop: The next-hop address that is used to reach the destination.

Origin: Indicates how BGP learned a particular route. There are three possible types — IGP (route is internal to the AS), EGP (learned via EBGP), or Incomplete (origin unknown or learned in a different way).

WELL-KNOWN, DISCRETIONARY

Local Preference: Defines the preferred exit point from the local AS for a specific route.

Atomic Aggregate: Set if a router advertises an aggregate causes path attribute information to be lost.

OPTIONAL, TRANSITIVE

Aggregator: Specifies the router ID and AS of the router that originated an aggregate prefix. Used in conjunction with the atomic aggregate attribute.

Community: Used to group routes that share common properties so that policies can be applied at the group level.

OPTIONAL, NON-TRANSITIVE

Multi-exit-discriminator (MED): Indicates the preferred path into an AS to external neighbors when multiple paths exist.

A list of path attributes is contained in BGP update messages. The attribute is variable length and consists of three fields: Attribute type consisting of a 1-byte attribute flags field and a 1-byte attribute code field, Attribute length field that is 1 or 2 bytes, and a variable length attribute value field. The attribute type codes used by Cisco are: 1-origin, 2-AS-path, 3-Next-hop, 4-MED, 5-Local preference, 6-Atomic aggregate, 7-aggregator, 8-community, 9-originator-ID, and 10-cluster list.

This article discussed the BGP attributes with the intent of preparing you for those confusing questions on the BSCN or BSCI exams. Hopefully, there is no more confusion on the various attributes that are used in the Cisco implementation of BGP.

BGP Path Selection

May 9, 2007 at 2:12 pm | Posted in BGP, Routing | Leave a comment

http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/bgp.htm 

BGP could possibly receive multiple advertisements for the same route from multiple sources. BGP selects only one path as the best path. When the path is selected, BGP puts the selected path in the IP routing table and propagates the path to its neighbors. BGP uses the following criteria, in the order presented, to select a path for a destination:

If the path specifies a next hop that is inaccessible, drop the update.

Prefer the path with the largest weight.

If the weights are the same, prefer the path with the largest local preference.

If the local preferences are the same, prefer the path that was originated by BGP running on this router.

If no route was originated, prefer the route that has the shortest AS_path.

If all paths have the same AS_path length, prefer the path with the lowest origin type (where IGP is lower than EGP, and EGP is lower than incomplete).

If the origin codes are the same, prefer the path with the lowest MED attribute.

If the paths have the same MED, prefer the external path over the internal path.

If the paths are still the same, prefer the path through the closest IGP neighbor.

Prefer the path with the lowest IP address, as specified by the BGP router ID.

OSPF network types

May 6, 2007 at 11:35 pm | Posted in OSPF | 1 Comment

Point to point:

Hello and LSA are sent to 224.0.0.5. No DR/BDR is required.

Point to multipoint:

This network types must be statically defined. The router treat frame-relay multipoint network like many point-to-point links. No DR/BDR is elected. OSPF packets are multicast.

Broadcast:

Hellos are sent to 224.0.0.5
LSA are sent to 224.0.0.6. Only DR and BDR listen to this address.
NBMA:

Neighbors are statically defined. DR & BDR are elected based on priority (which should be configured manually), and other tie break parameters. DR/BDR should be the hub routers. All OSPF packets are unicast.

OSPF NSSA routes: O IA, O N1, O N2

May 6, 2007 at 10:03 pm | Posted in Blogroll, OSPF, Routing | Leave a comment

In addition to the Intra Area type (O), the following route types can exist in an NSSA router. 

 CE1#sh run

interface FastEthernet0
 ip address 50.50.50.10 255.255.255.0
 speed 10
 full-duplex
!
interface Serial0
 ip address 32.29.1.2 255.255.255.252
 clockrate 4000000

router ospf 100
 log-adjacency-changes
 area 1 nssa
 network 32.29.1.2 0.0.0.0 area 1
 network 50.50.50.0 0.0.0.255 area 1

CE1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

S    200.200.200.0/24 is directly connected, Null0
     50.0.0.0/24 is subnetted, 1 subnets
C       50.50.50.0 is directly connected, FastEthernet0
     32.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       32.34.1.1/32 is directly connected, Loopback0
O IA    32.29.1.12/30 [110/192] via 32.29.1.1, 00:04:48, Serial0
O IA    32.29.1.8/30 [110/128] via 32.29.1.1, 00:04:48, Serial0
C       32.29.1.0/30 is directly connected, Serial0
O N1 130.130.0.0/16 [110/84] via 32.29.1.1, 00:03:47, Serial0
     165.87.0.0/32 is subnetted, 3 subnets
O IA    165.87.1.3 [110/193] via 32.29.1.1, 00:04:49, Serial0
O IA    165.87.1.2 [110/129] via 32.29.1.1, 00:04:49, Serial0
O IA    165.87.1.1 [110/65] via 32.29.1.1, 00:04:49, Serial0
O N2 150.150.0.0/16 [110/20] via 50.50.50.150, 00:04:50, FastEthernet0
CE1#

ISIS configuration and show commands

May 6, 2007 at 6:33 pm | Posted in Blogroll | 1 Comment

PE1#sh run
!
!        
interface Loopback0
 ip address 165.87.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 50.50.50.2 255.255.255.0
 ip router isis
 speed 10
 full-duplex
!
!
interface Serial0/1
 ip address 32.29.1.1 255.255.255.252
 ip router isis
!
!
interface Serial0/3
 ip address 32.29.1.10 255.255.255.252
 ip router isis
!        
router isis
 net 00.0001.000b.5f76.7280.00
 is-type level-2-only
!        
!
end

PE1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 1 subnets
C       50.50.50.0 is directly connected, FastEthernet0/0
     32.0.0.0/30 is subnetted, 5 subnets
C       32.29.1.24 is directly connected, Serial0/0
i L2    32.29.1.20 [115/30] via 50.50.50.3, FastEthernet0/0
                   [115/30] via 32.29.1.9, Serial0/3
i L2    32.29.1.12 [115/20] via 50.50.50.3, FastEthernet0/0
                   [115/20] via 32.29.1.9, Serial0/3
C       32.29.1.8 is directly connected, Serial0/3
C       32.29.1.0 is directly connected, Serial0/1
     165.87.0.0/32 is subnetted, 1 subnets
C       165.87.1.1 is directly connected, Loopback0
PE1#sh isis da
PE1#sh isis database

IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
P1.00-00              0x00000116   0x6312        890               0/0/0
PE1.00-00           * 0x00000111   0xB381        437               0/0/0
PE1.01-00           * 0x00000097   0x9CFF        744               0/0/0
PE1#sh isis nei
PE1#sh isis neighbors

System Id      Type Interface IP Address      State Holdtime Circuit Id
P1             L2   Fa0/0     50.50.50.3      UP    29       PE1.01            
P1             L2   Se0/3     32.29.1.9       UP    24       00
PE1#sh isis topo
IS-IS paths to level-2 routers
System Id            Metric     Next-Hop             Interface   SNPA
P1                   10         P1                   Se0/3       *HDLC*        
                                P1                   Fa0/0       000b.5f63.1620
PE1                  —
P1#sh run
!        
interface Loopback0
 ip address 165.87.1.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 50.50.50.3 255.255.255.0
 ip router isis
 speed 10
 full-duplex
!
interface Serial0/0
 ip address 32.29.1.9 255.255.255.252
 ip router isis
 clock rate 2000000
!
interface Serial0/1
 ip address 32.29.1.13 255.255.255.252
 ip router isis
 clock rate 2000000
!        
router isis
 net 00.0002.000b.5f63.1620.00
!
!
end

P1#sh isis nei

System Id      Type Interface IP Address      State Holdtime Circuit Id
PE2            L1   Fa0/0     50.50.50.1      UP    7        PE2.01            
PE2            L1   Se0/1     32.29.1.14      UP    22       00
PE1            L2   Fa0/0     50.50.50.2      UP    8        PE1.01            
PE1            L2   Se0/0     32.29.1.10      UP    27       01
P1#sh isis data

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
P1.00-00            * 0x00000117   0x8356        845               1/0/0
PE2.00-00             0x00000116   0x7837        1157              0/0/0
PE2.01-00             0x0000009B   0x335B        651               0/0/0
R5.00-00              0x00000106   0xD4E6        781               0/0/0
IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
P1.00-00            * 0x00000116   0x6312        718               0/0/0
PE1.00-00             0x00000112   0xB182        1149              0/0/0
PE1.01-00             0x00000097   0x9CFF        568               0/0/0
P1#sh isis topo

IS-IS paths to level-1 routers
System Id            Metric     Next-Hop             Interface   SNPA
P1                   —
PE2                  10         PE2                  Se0/1       *HDLC*        
                                PE2                  Fa0/0       0014.f27f.ae60
R5                   20         PE2                  Se0/1       *HDLC*        
                                PE2                  Fa0/0       0014.f27f.ae60

IS-IS paths to level-2 routers
System Id            Metric     Next-Hop             Interface   SNPA
P1                   —
PE1                  10         PE1                  Se0/0       *HDLC*        
                                PE1                  Fa0/0       000b.5f76.7280

P1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 1 subnets
C       50.50.50.0 is directly connected, FastEthernet0/0
     32.0.0.0/30 is subnetted, 4 subnets
i L1    32.29.1.20 [115/20] via 50.50.50.1, FastEthernet0/0
                   [115/20] via 32.29.1.14, Serial0/1
C       32.29.1.12 is directly connected, Serial0/1
C       32.29.1.8 is directly connected, Serial0/0
i L2    32.29.1.0 [115/20] via 50.50.50.2, FastEthernet0/0
                  [115/20] via 32.29.1.10, Serial0/0
     165.87.0.0/32 is subnetted, 1 subnets
C       165.87.1.2 is directly connected, Loopback0

PE2#sh run
!        
interface Loopback0
 ip address 165.87.1.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 50.50.50.1 255.255.255.0
 ip router isis
 speed 10
 full-duplex
 isis priority 120
!
!
interface Serial0/1
 ip address 32.29.1.21 255.255.255.252
 ip router isis
!
!
interface Serial0/3
 ip address 32.29.1.14 255.255.255.252
 ip router isis
 isis metric 1
!
!
router isis
 net 00.0002.0014.f27f.ae60.00
 is-type level-1
 redistribute connected
!
end

PE2#sh isis nei

System Id      Type Interface IP Address      State Holdtime Circuit Id
P1             L1   Fa0/0     50.50.50.3      UP    26       PE2.01            
P1             L1   Se0/3     32.29.1.13      UP    24       01
R5             L1   Se0/1     32.29.1.22      UP    29       00
PE2#sh isis data

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
P1.00-00              0x00000117   0x8356        661               1/0/0
PE2.00-00           * 0x00000116   0x7837        977               0/0/0
PE2.01-00           * 0x0000009B   0x335B        472               0/0/0
R5.00-00              0x00000106   0xD4E6        602               0/0/0
PE2#sh isis topo

IS-IS paths to level-1 routers
System Id            Metric     Next-Hop             Interface   SNPA
P1                   1          P1                   Se0/3       *HDLC*        
PE2                  —
R5                   10         R5                   Se0/1       *HDLC* 

R5#sh run
interface Loopback0
 ip address 32.34.1.3 255.255.255.255
!
!
interface Serial1
 ip address 32.29.1.22 255.255.255.252
 ip router isis
 clockrate 56000
 no cdp enable
!
!
router isis
 net 00.0002.00e0.1e67.f6fe.00
 is-type level-1
!
ip classless
!
end
R5#sh clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
PE2            Se1         *HDLC*              Up     27        L1   IS-IS
R5#sh isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
P1.00-00              0x00000117   0x8356        438               1/0/0
PE2.00-00             0x00000116   0x7837        754               0/0/0
PE2.01-00             0x0000009C   0x315C        991               0/0/0
R5.00-00            * 0x00000106   0xD4E6        383               0/0/0
R5#sh isis topo

IS-IS paths to level-1 routers
System Id             Metric  Next-Hop              Interface   SNPA
P1                    11      PE2                   Se1         *HDLC*         
PE2                   10      PE2                   Se1         *HDLC*         
R5                    —
R5#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
       i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
       * – candidate default, U – per-user static route, o – ODR
       P – periodic downloaded static route

Gateway of last resort is 32.29.1.21 to network 0.0.0.0

     50.0.0.0/24 is subnetted, 1 subnets
i L1    50.50.50.0 [115/20] via 32.29.1.21, Serial1
     32.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       32.34.1.3/32 is directly connected, Loopback0
C       32.29.1.20/30 is directly connected, Serial1
i L1    32.29.1.12/30 [115/11] via 32.29.1.21, Serial1
i L1    32.29.1.8/30 [115/21] via 32.29.1.21, Serial1
i*L1 0.0.0.0/0 [115/11] via 32.29.1.21, Serial1

Show ISIS DIS on a LAN segment

May 5, 2007 at 9:43 am | Posted in Blogroll, IS-IS | Leave a comment

PE2#sh run int fa0/0
Building configuration…

Current configuration : 129 bytes
!
interface FastEthernet0/0
 ip address 50.50.50.1 255.255.255.0
 ip router isis
 speed 10
 full-duplex
 isis priority 120
end

PE2#sh clns interface fa0/0
FastEthernet0/0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  ERPDUs enabled, min. interval 10 msec.
  RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
  Congestion Experienced bit set at 4 packets
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 46 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x2, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 120, Circuit ID: PE2.01
    DR ID: PE2.01
    Level-1 IPv6 Metric: 10
    Number of active level-1 adjacencies: 1
    Next IS-IS LAN Level-1 Hello in 1 seconds
PE2#

 P1#sh run int fa0/0
Building configuration…

Current configuration : 110 bytes
!
interface FastEthernet0/0
 ip address 50.50.50.3 255.255.255.0
 ip router isis  ! default priority is 64 
 speed 10
 full-duplex
end

P1#sh clns interface fa0/0
FastEthernet0/0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  ERPDUs enabled, min. interval 10 msec.
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 17 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x2, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: PE2.01
    DR ID: PE2.01
    Level-1 IPv6 Metric: 10
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: PE1.01
    DR ID: PE1.01
    Level-2 IPv6 Metric: 10
    Number of active level-2 adjacencies: 1
    Next IS-IS LAN Level-1 Hello in 1 seconds
    Next IS-IS LAN Level-2 Hello in 6 seconds
P1#

Create a free website or blog at WordPress.com.
Entries and comments feeds.